Sie sind auf Seite 1von 7

Select Page If you continue to browse this website, you are allowing all third-party services ✓ OK, accept

OK, accept all Personalize


Rechercher

Select Page

RÉSEAUX 0

Le routage inter-vlan sur nos équipements Cisco

Cet article est la suite de mon article sur la configuration des VLAN. Dans cet article nous allons voir
comment permettre à deux membres de VLAN diffèrents de communiquer.
Partager cet article

Prérequis

Connaitre le fonctionnement et les différents modes d’IOS.


Avoir des bases en réseau (IP, masque de sous réseau…).
Savoir configurer un VLAN.

Introduction au routage Inter-VLAN

Dans l’article précèdent nous avons vue comment configurer nos VLANs ce qui nous amenait à avoir une infrastructure similaire à l’exemple suivant :

Dans cet exemple nous avons configuré deux VLAN le 10 et le 20, par conséquent nous avons segmenté notre réseau local en deux sous réseaux.
Il est alors impossible pour un hôte se trouvant dans le VLAN 10 de communiquer avec un hôte du VLAN 20.
Cependant il existe un moyen pour permettre cette communication, il s’agit du routage inter-VLAN, celui-ci va nous permettre d’acheminer du trafic
d’un VLAN à un autre.
Le routage entre nos VLANs peut s’implémenter de différentes manières, soit par l’utilisation d’un routeur, soit grâce à un switch de couche 3.
Exemple d’utilisation d’un routeur.

Exemple d’utilisation d’un switch.


Dans cet article nous allons détailler l’utilisation d’un routeur distinct.

Routage inter-VLAN grâce à un routeur

Il existe deux moyens pour configurer le routage inter-VLAN, de façon logique et de façon physique.

Routage Inter-VLAN physique


Le routage Inter-VLAN physique utilise plusieurs liens physiques pour permettre aux différents VLAN de communiquer entre eux. En effet nous
allons utiliser un lien physique par VLAN.
Dans cet exemple nous avons deux VLANs donc deux liens physiques.
Pour configurer notre routage inter-VLAN il nous faut d’abord configurer notre switch 2 pour que l’interface Fa0/3 soit dans le VLAN 10 et que
l’interface FA0/4 soit dans le Vlan 20.

Switch(config)#interface fastEthernet 0/3


Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#no shutdown
Switch(config-if)#exit

Ensuite il nous faut configurer les adresses IP de nos interfaces du routeur pour qu’il correspondent au bon sous réseau.

Router(config)#interface fastEthernet 0/0


Router(config-if)#ip address 10.1.10.5 255.255.255.0
Router(config-if)#no shutdown
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 10.1.20.5 255.255.255.0
Router(config-if)#no shutdown

Voilà notre routage inter-VLAN est configurée il est maintenant possible de communiquer entre les VLAN à condition de désigner comme passerelle
par défaut de nos ordinateurs l’adresse IP de l’interface du routeur correspondant au VLAN auquel appartient l’ordinateur.

Routage Inter-VLAN logique (Router on a stick)

Maintenant que nous avons vu comment configurer le routage Inter-VLAN de manière physique nous allons voir comment le faire de façon logique.
L’avantage de cette méthode est qu’elle va utiliser un seul lien pour propager tous nos VLANs (dans l’exemple précèdent nous avions deux VLANs
donc deux liens, imaginer si nous avons vingt VLAN, il faudrait 20 liens) ce qui est un avantage considérable. Un routeur mis en place dans cette
configuration est appelé « Router on a stick ».
Pour configurer notre routage inter-VLAN il faut d’abord configurer un trunk sur l’interface FA0/3 du switch 2:

Switch(config-if)#interface fastEthernet 0/3


Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport native vlan 99
Switch(config-if)#no shutdown

Puis il nous faut configurer notre routeur. Pour cela nous allons créer des sous interfaces.

Router(config)#interface fastEthernet 0/0.10


Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 10.1.10.5 255.255.255.0
Router(config-subif)#interface Fa0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 10.1.20.5 255.255.255.0
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown

Nous avons donc créé deux sous interface Fa0/0.10 et Fa0/0.20 l’une pour le VLAN 10 et l’autre pour le VLAN 20. Notez que l’interface physique
doit être allumée avec que le routage inter-VLAN fonctionne.
Notre routage inter-VLAN est configuré nos VLAN peuvent maintenant communiquer entre eux à condition de désigner comme passerelle par défaut
de nos ordinateurs l’adresse IP de l’interface du routeur correspondant au VLAN auquel appartient l’ordinateur.

Conclusion

Cet article se termine, et nous avons vu ensemble comment configurer le routage inter-VLAN, nous sommes maintenant capable de permettre à nos
VLANs d’échanger du trafic.

Avez-vous des questions ?Cédric ROBERT

Tagged with: cisco, cofniguration, itner-vlan, mis en place, routage, router on a stick, routeur, switch, VLAN

Gérer des vues en MySQL Restriction logicielle avec AppLocker

Articles liés
Configurer des VLAN sur nos équipements Cisco et le NTP : Synchronisez les horloges

7 Cisco 0 de vos équipements

Agrégez vos liens sur les équipements Une bonne politique de mot de passe sur

1 Cisco 0 votre équipement Cisco

Les ACLs sur les équipements Cisco

Laisser un commentaire

your name

email@address.co.uk

www

I'm not a robot


reCAPTCHA

Votre commentaire

COMMENTER

493 511

Premier livre sur Centreon

Découvrez le premier livre français sur Centreon co-rédigé par le fondateur de ce blog :
Quel est la catégorie que vous lisez le plus ?
Base de données Supervision

Microsoft Linux

Réseaux Sécurité

Autre

VOTE

Voir les résultats

Publicité

Liens

Centreon Lolokai Conseil

Mon Curriculum Vitae

Ici on parle de …

c# centreon cisco configuration developpement dns esx esxi fonctionnement gestion google installation ios
centos
iphone linux microsoft mise en place mise à jour mysql nagios nagvis netw ork oracle plugins protection présentation réseau réseaux

sauvegarde securite securité server serveur SQL supervision sécurité ubuntu vcenter virtualisation vmware vsphere web Windows
wordpress
Le fondateur

Passionné de supervision, virtualisation et réseaux, Loïc FONTAINE fonde Lolok ai Conseil en 2013 avec comme objectif de devenir une société experte en
supervision et automatisation. Sa passion l'a conduit naturellement à fonder un blog afin de présenter son travail en collaboration avec différents
rédacteurs. Il est également l'auteur d'un ouvrage sur Centreon publié aux éditions ENI.

Lolokai - Informatique depuis 2011