Sie sind auf Seite 1von 18

2018

EIGRP Basic
Configuration for
CCNA Students
By
Eng. Abeer Hosni
EIGRP Configuration
Lab 1 (EIGRP Configuration):

R1(config)#int f0/0

R1(config-if)#ip address 10.0.0.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#int loop 1

R1(config-if)#ip address 1.1.1.1 255.255.255.255

R2(config)#int f0/1

R2(config-if)#ip address 10.0.0.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#int loop 2

R2(config-if)#ip address 2.2.2.2 255.255.255.255

R1#show ip route

<Output omitted>

1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.1 is directly connected, Loopback1

10.0.0.0/24 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, FastEthernet0/0


R2#show ip route

<Output omitted>

2.0.0.0/32 is subnetted, 1 subnets

C 2.2.2.2 is directly connected, Loopback2

10.0.0.0/24 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, FastEthernet0/1

 Now to run EIGRP:

R1(config)#router eigrp 1

R1(config-router)#network 10.0.0.1 0.0.0.0

R1(config-router)#network 1.1.1.1 0.0.0.0

R1(config-router)#no auto-summary

R2(config)#router eigrp 1

R2(config-router)#network 10.0.0.2 0.0.0.0

R2(config-router)#network 2.2.2.2 0.0.0.0

R2(config-router)#no auto-summary

 To see the neighbors table:

R1#show ip eigrp neighbors

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.0.0.2 Fa0/0 11 00:01:03 99 594 0 8


R2#show ip eigrp neighbors

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.0.0.1 Fa0/1 12 00:03:10 575 3450 0 9

 To see the routing table:

R1#show ip route eigrp

<Output omitted>

2.0.0.0/32 is subnetted, 1 subnets

D 2.2.2.2 [90/409600] via 10.0.0.2, 00:05:48, FastEthernet0/0

R2#show ip route eigrp

<Output omitted>

1.0.0.0/32 is subnetted, 1 subnets

D 1.1.1.1 [90/409600] via 10.0.0.1, 00:06:21, FastEthernet0/1

Now the network should be pingable:

R1#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/20/44ms


R2#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/39/72 ms

 To see the topology table:

R1#show ip eigrp topology

<Output omitted>

P 2.2.2.2/32, 1 successors, FD is 409600 via

10.0.0.2 (409600/128256), FastEthernet0/0

P 1.1.1.1/32, 1 successors, FD is 128256 via

Connected, Loopback1

P 10.0.0.0/24, 1 successors, FD is 281600

via Connected, FastEthernet0/0

Where 409600 is the feasible distance and 128256 is the reported or advertised distance and must be
less than the feasible distance.

R2#show ip eigrp topology

<Output omitted>

P 2.2.2.2/32, 1 successors, FD is 128256

via Connected, Loopback2

P 1.1.1.1/32, 1 successors, FD is 409600 via

10.0.0.1 (409600/128256), FastEthernet0/1

P 10.0.0.0/24, 1 successors, FD is 281600 via

Connected, FastEthernet0/1
Lab 2 (EIGRP Authentication):

We will run authentication on the same previous lab.

 First we will create the key chain.

R1(config)#key chain CHA1

R1(config-keychain)#key 1

R1(config-keychain-key)#key-string CCNA

 Second we will apply the key chain at the interface level.

R1(config)#int f0/0

R1(config-if)#ip authentication key-chain eigrp 1 CHA1

R1(config-if)#ip authentication mode eigrp 1 md5

And now the adjacency will come down.

*Mar 1 00:26:58.963: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.2 (FastEthernet0/0) is


down: authentication mode changed

R1#debug eigrp packets

*Mar 1 00:28:06.791: EIGRP: Sending HELLO on Loopback1

*Mar 1 00:28:06.791: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

*Mar 1 00:28:06.795: EIGRP: Received HELLO on Loopback1 nbr 1.1.1.1

*Mar 1 00:28:06.799: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0


*Mar 1 00:28:06.799: EIGRP: Packet from ourselves ignored

*Mar 1 00:28:07.135: EIGRP: Sending HELLO on FastEthernet0/0

*Mar 1 00:28:07.135: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

*Mar 1 00:28:07.383: EIGRP: FastEthernet0/0: ignored packet from 10.0.0.2, opcode = 5 (missing
authentication)

Now we will run authentication on R2.

R2(config)#key chain CHA2

R2(config-keychain)#key 1

R2(config-keychain-key)#key-string CCNA

R2(config-keychain-key)#int f0/1

R2(config-if)#ip authentication key-chain eigrp 1 CHA2

R2(config-if)#ip authentication mode eigrp 1 md5

Now the adjacency will come back up.

*Mar 1 00:31:41.911: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.1 (FastEthernet0/1) is


up: new adjacency

Lab 3 (Auto summarization):

R1(config)#int f0/0

R1(config-if)#ip address 10.0.0.1 255.255.255.0


R1(config-if)#no shutdown

R1(config-if)#router eigrp 1

R1(config-router)#network 10.0.0.1 0.0.0.0

R2(config)#int f0/1

R2(config-if)#ip address 10.0.0.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#int loop 1

R2(config-if)#ip address 11.1.0.2 255.255.255.0

R2(config-if)#int loop 2

R2(config-if)#ip address 11.2.0.2 255.255.255.0

R2(config-if)#int loop 3

R2(config-if)#ip address 11.3.0.2 255.255.255.0

R2(config-if)#int loop 4

R2(config-if)#ip address 11.4.0.2 255.255.255.0

R2(config-if)#router eigrp 1

R2(config-router)#network 10.0.0.2 0.0.0.0

R2(config-router)#network 11.0.0.0 0.255.255.255

R1#show ip route eigrp

<Output omitted>

D 11.0.0.0/8 [90/409600] via 10.0.0.2, 00:02:03, FastEthernet0/0

R1 can see the summarized address and if we want R1 to see the more specific routes, we will run the
no auto-summary command at the router that advertises the routes, R2.

R2(config)#router eigrp 1
R2(config-router)#no auto-summary

Hint:
Auto summary is disabled since IOS version 15.x

R1#show ip route eigrp

<Output omitted>

11.0.0.0/24 is subnetted, 4 subnets

D 11.3.0.0 [90/409600] via 10.0.0.2, 00:00:34, FastEthernet0/0

D 11.2.0.0 [90/409600] via 10.0.0.2, 00:00:34, FastEthernet0/0

D 11.1.0.0 [90/409600] via 10.0.0.2, 00:00:34,

FastEthernet0/0 D 11.4.0.0 [90/409600] via 10.0.0.2,

00:00:34, FastEthernet0/0

Lab 4 (Manual summarization):


We will run manual summarization at the previous lab.

11.1.0.0 00001011.00000001.00000000.00000000

11.2.0.0 00001011.00000010.00000000.00000000

11.3.0.0 00001011.00000011.00000000.00000000

11.4.0.0 00001011.00000100.00000000.00000000

The summarized address is 11.0.0.0 and the subnet mask is 255.248.0.0

The summarized address is run at the interface level.

R2(config)#int f0/1

R2(config-if)#ip summary-address eigrp 1 11.0.0.0 255.248.0.0

R1#show ip route eigrp

<Output omitted>
11.0.0.0/13 is subnetted, 1 subnets

D 11.0.0.0 [90/409600] via 10.0.0.2, 00:00:32, FastEthernet0/0

Lab 5 (Auto summarization problems):

R1(config)#int f0/0

R1(config-if)#ip address 10.0.0.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#int f0/1

R1(config-if)#ip address 11.0.0.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#router eigrp 1

R1(config-router)#network 10.0.0.1 0.0.0.0


R1(config-router)#network 11.0.0.1 0.0.0.0

R2(config)#int f0/0

R2(config-if)#ip address 10.0.0.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#int loop 0

R2(config-if)#ip address 12.0.0.2 255.255.255.0

R2(config-if)#int loop 1

R2(config-if)#ip address 12.1.0.2 255.255.255.0

R2(config-if)#router eigrp 1

R2(config-router)#network 12.0.0.2 0.0.0.0

R2(config-router)#network 12.1.0.2 0.0.0.0

R2(config-router)#network 10.0.0.2 0.0.0.0

R3(config)#int f0/1

R3(config-if)#ip address 11.0.0.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#int loop 0

R3(config-if)#ip address 12.2.0.3 255.255.255.0

R3(config-if)#int loop 1

R3(config-if)#ip address 12.3.0.3 255.255.255.0

R3(config-if)#router eigrp 1

R3(config-router)#network 11.0.0.3 0.0.0.0

R3(config-router)#network 12.2.0.3 0.0.0.0

R3(config-router)#network 12.3.0.3 0.0.0.0


R1#show ip route eigrp

<Output omitted>

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 10.0.0.0/8 is a summary, 00:06:29, Null0

11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 11.0.0.0/8 is a summary, 00:05:44, Null0

D 12.0.0.0/8 [90/409600] via 11.0.0.3, 00:00:34, FastEthernet0/1

[90/409600] via 10.0.0.2, 00:00:34, FastEthernet0/0

R1 thinks that if it wishes to reach the 10.0.0.0 networks, it will run equal cost load balance and that
will cause strange behaviors.

R1#ping 12.0.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.0.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/40/72 ms

R1#ping 12.1.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.1.0.2, timeout is 2 seconds:

U.U.U

Success rate is 0 percent (0/5)

R1#ping 12.2.0.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.2.0.3, timeout is 2 seconds:

!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/60/108 ms

R1#ping 12.3.0.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.3.0.3, timeout is 2 seconds:

U.U.U

Success rate is 0 percent (0/5)

So we will run no auto-summary at R2 and R3.

R2(config)#router eigrp 1

R2(config-router)#no auto-summary

R3(config)#router eigrp 1

R3(config-router)#no auto-summary

R1#show ip route eigrp

<Output omitted>

10.0.0.0/8 is variably subnetted, 2 subnets, 2

masks D 10.0.0.0/8 is a summary, 00:14:17, Null0

11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 11.0.0.0/8 is a summary, 00:13:33, Null0

12.0.0.0/24 is subnetted, 4 subnets

D 12.0.0.0 [90/409600] via 10.0.0.2, 00:01:19, FastEthernet0/0

D 12.1.0.0 [90/409600] via 10.0.0.2, 00:01:19, FastEthernet0/0


D 12.2.0.0 [90/409600] via 11.0.0.3, 00:00:20,

FastEthernet0/1 D 12.3.0.0 [90/409600] via 11.0.0.3,

00:00:20, FastEthernet0/1

And the network should be pingable now.

R1#ping 12.0.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.0.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/52/92 ms

R1#ping 12.1.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.1.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/55/104 ms

R1#ping 12.2.0.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.2.0.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/48/88 ms

R1#ping 12.3.0.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.3.0.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/59/88 ms


Lab 6 (The variance command):

R1(config)#int s1/0

R1(config-if)#ip address 10.0.0.1 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#int s1/1

R1(config-if)#ip address 11.0.0.1 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#router eigrp 1

R1(config-router)#no auto-summary

R1(config-router)#network 10.0.0.1 0.0.0.0

R1(config-router)#network 11.0.0.1 0.0.0.0

R2(config)#int s1/0

R2(config-if)#ip address 10.0.0.2 255.255.255.252

R2(config-if)#no shutdown

R2(config-if)#int f0/0
R2(config-if)#ip add 12.0.0.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#int loop 2

R2(config-if)#ip address 2.2.2.2 255.255.255.255

R2(config-if)#router eigrp 1

R2(config-router)#no auto-summary

R2(config-router)#network 10.0.0.2 0.0.0.0

R2(config-router)#network 12.0.0.2 0.0.0.0

R2(config-router)#network 2.2.2.2 0.0.0.0

R3(config)#int s1/1

R3(config-if)#ip address 11.0.0.2 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#int f0/0

R3(config-if)#ip address 12.0.0.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#router eigrp 1

R3(config-router)#no auto-summary

R3(config-router)#network 11.0.0.2 0.0.0.0

R3(config-router)#network 12.0.0.3 0.0.0.0

R1#show ip route eigrp

<Output omitted>

2.0.0.0/32 is subnetted, 1 subnets

D 2.2.2.2 [90/2297856] via 10.0.0.2, 00:00:36, Serial1/0


12.0.0.0/24 is subnetted, 1 subnets

D 12.0.0.0 [90/2195456] via 11.0.0.2, 00:00:38, Serial1/1

[90/2195456] via 10.0.0.2, 00:00:38, Serial1/0

We want R1 to reach the 2.2.2.2/32 network using un-equal cost load balance via R2 and R3. But to
accomplish that, the route via R3 must exist in the topology table.

R1#show ip eigrp topology

<Output omitted>

P 2.2.2.2/32, 1 successors, FD is 2297856

via 10.0.0.2 (2297856/128256), Serial1/0

via 11.0.0.2 (2323456/409600), Serial1/1

P 10.0.0.0/24, 1 successors, FD is

2169856 via Connected, Serial1/0

P 11.0.0.0/24, 1 successors, FD is 2169856

via Connected, Serial1/1

P 12.0.0.0/24, 2 successors, FD is 2195456 via 10.0.0.2

(2195456/281600), Serial1/0 via 11.0.0.2

(2195456/281600), Serial1/1

R1(config)#router eigrp 1

R1(config-router)#variance 2

Now, un-equal cost load balance has been accomplished.

R1#show ip route eigrp

<Output omitted>

2.0.0.0/32 is subnetted, 1 subnets

D 2.2.2.2 [90/2323456] via 11.0.0.2, 00:00:56, Serial1/1


[90/2297856] via 10.0.0.2, 00:00:56, Serial1/0

12.0.0.0/24 is subnetted, 1 subnets

D 12.0.0.0 [90/2195456] via 11.0.0.2, 00:00:56, Serial1/1

[90/2195456] via 10.0.0.2, 00:00:56, Serial1/0

R1#traceroute 2.2.2.2

Type escape sequence to abort.

Tracing the route to 2.2.2.2

1 11.0.0.3 52 msec

10.0.0.2 60 msec

11.0.0.3 28 msec

Configure bandwidth utilization for EIGRP:


By default, EIGRP will limit itself to using no more than 50% of the interface bandwidth.

R(config)# interface s1/0

R(config-if)# ip bandwidth-percent eigrp 1 75

Configure the hello interval and hold timer for EIGRP:


R(config)# interface s1/0

R(config-if)# ip hello-interval eigrp 1 60

R(config-if)# ip hold-time eigrp 1 180

Best Wishes

Abeer 

Das könnte Ihnen auch gefallen