Sie sind auf Seite 1von 9

Comunicación de datos II.

Guía 3 1

Facultad: Ingeniería
Escuela: Electrónica
Asignatura: Comunicación de datos II

Tema: Enrutamiento dinámico RIP v2

Contenidos

Configuración Básica de los Router.


Configuración del protocolo RIP v2
Configurar los IP Host en los routers.
Redistribución de rutas por defecto.

Objetivos Específicos
Uso de VLSM
Aplicar la configuración para el protocolo RIP v2.
Comprobar el buen funcionamiento de RIP v2
Configuración de los HOST en los routers

Materiales y Equipo
Computadora con simulador Packet Tracer

Procedimiento

Configuración
Bibliografía Básica de los Router.

1- Realizar la siguiente configuración de red


Guía 1
2 Comunicación de datos II. Guía 3

2- Realizar la configuración necesaria para cada uno de los router.

a. Configuración del Router0

Router>enable
Router#configure terminal
Router(config)#hostname GAUS
GAUS(config)#enable secret cisco
GAUS(config)#line vty 0 4
GAUS(config-line)#password cisco
GAUS(config-lin)#login
GAUS(config-line)#exit
GAUS(config)#line console 0
GAUS(config-line)#password cisco
GAUS(config-lin)#login
GAUS(config-line)#exit
GAUS(config)#interface FastEthernet 0/0
GAUS(config-if)#ip address 172.16.3.149 255.255.255.252
GAUS(config-if)#description Enlace FastEthernet con INTERNET
GAUS(config-if)#no shutdown
GAUS(config-if)#exit
GAUS(config)#interface FastEthernet 0/1
GAUS(config-if)#ip address 172.16.3.129 255.255.255.248
GAUS(config-if)#description Enlace FastEthernet con la red LAN de GAUS
GAUS(config-if)#no shutdown
GAUS(config-if)#exit
GAUS(config)#interface Serial 0/0
GAUS(config-if)# ip address 172.16.3.141 255.255.255.252
GAUS(config-if)#description Enlace Serial punto a punto con la interfaz Serial 0/0 de ERA
GAUS(config-if)#clock rate 56000
GAUS(config-if)#bandwidth 128
GAUS(config-if)#no shutdown
GAUS(config-if)#exit
GAUS(config)#interface Serial 0/1
GAUS(config-if)# ip address 172.16.3.137 255.255.255.252
GAUS(config-if)#description Enlace Serial punto a punto con la interfaz Serial 0/0 de ORION
GAUS(config-if)#clock rate 56000
GAUS(config-if)#bandwidth 1024
GAUS(config-if)#no shutdown
GAUS(config-if)#exit
GAUS(config)#exit
GAUS(config)#copy running-config startup-config

b. Configuración del Router1

Router>enable
Router#configure terminal
Router(config)#hostname ORION
ORION(config)#enable secret cisco
ORION(config)#line vty 0 4
Comunicación de datos II. Guía 3 3

ORION(config-line)#password cisco
ORION(config-lin)#login
ORION(config-line)#exit
ORION(config)#line console 0
ORION(config-line)#password cisco
ORION(config-lin)#login
ORION(config-line)#exit
ORION(config)#interface FastEthernet 0/0
ORION(config-if)#ip address 172.16.3.1 255.255.255.192
ORION(config-if)#description Enlace FastEthernet con la red LAN 1 de ORION
ORION(config-if)#no shutdown
ORION(config-if)#exit
ORION(config)#interface FastEthernet 0/1
ORION(config-if)#ip address 172.16.3.65 255.255.255.192
ORION(config-if)#description Enlace FastEthernet con la red LAN 2 de ORION
ORION(config-if)#no shutdown
ORION(config-if)#exit
ORION(config)#interface Serial 0/0
ORION(config-if)# ip address 172.16.3.138 255.255.255.252
ORION(config-if)#bandwidth 1024
ORION(config-if)#description Enlace Serial punto a punto con la interfaz Serial 0/1 de GAUS
ORION(config-if)#no shutdown
ORION(config-if)#exit
ORION(config)#interface Serial 0/1
ORION(config-if)# ip address 172.16.3.146 255.255.255.252
ORION(config-if)#description Enlace Serial punto a punto con la interfaz Serial 0/1 de ERA
ORION(config-if)#bandwidth 1024
ORION(config-if)#no shutdown
ORION(config-if)#exit
ORION(config)#exit
ORION(config)#copy running-config startup-config

c. Configuración del Router3

Router>enable
Router#configure terminal
Router(config)#hostname ERA
ERA(config)#enable secret cisco
ERA(config)#line vty 0 4
ERA(config-line)#password cisco
ERA(config-lin)#login
ERA(config-line)#exit
ERA(config)#line console 0
ERA(config-line)#password cisco
ERA(config-lin)#login
ERA(config-line)#exit
ERA(config)#interface FastEthernet 0/0
ERA(config-if)#ip address 172.16.0.1 255.255.255.0
ERA(config-if)#description Enlace FastEthernet con la red LAN 1 de ERA
ERA(config-if)#no shutdown
4 Comunicación de datos II. Guía 3

ERA(config-if)#exit
ERA(config)#interface FastEthernet 0/2
ERA(config-if)#ip address 172.16.2.1 255.255.255.0
ERA(config-if)#description Enlace FastEthernet con la red LAN 2 de ERA
ERA(config-if)#no shutdown
ERA(config-if)#exit
ERA(config)#interface Serial 0/0
ERA(config-if)# ip address 172.16.3.142 255.255.255.252
ERA(config-if)#description Enlace Serial punto a punto con la interfaz Serial 0/0 de GAUS
ERA(config-if)#bandwidth 128
ERA(config-if)#no shutdown
ERA(config-if)#exit
ERA(config)#interface Serial 0/1
ERA(config-if)# ip address 172.16.3.145 255.255.255.252
ERA(config-if)#description Enlace Serial punto a punto con la interfaz Serial 0/1 de ORION
ERA(config-if)#clock rate 64000
ERA(config-if)#bandwidth 1024
ERA(config-if)#no shutdown
ERA(config-if)#exit
ERA(config)#exit
ERA(config)#copy running-config startup-config

3. Compruebe su configuración

a. Usando el comando show interface. Verifique la salida en los 3 routers


GAUS#show interface

b. Use el comando show cdp neighbors. Verifique la salida en los 3 routers


GAUS#show cdp neighbors

c. Ejecute pruebas con el comando ping.

Configuración del protocolo RIP v2

4. Configurar el protocolo RIPv2 en los tres enrutadores.

Revisar las redes que actualmente forman parte de la tabla de enrutamiento antes de
configurar el protocolo dinámico. Usar el comando show ip route. Deberían aparecer
únicamente las redes directamente conectadas.

a. Configuración de RIPv2 para GAUS

GAUS#configure terminal
GAUS(config)#router rip
GAUS(config-router)#version 2
GAUS(config-router)#network 172.16.3.128
GAUS(config-router)#network 172.16.3.140
GAUS(config-router)#network 172.16.3.136
GAUS(config-router)#CTRL+Z
Comunicación de datos II. Guía 3 5

b. Configuración de RIPv2 para ORION

ORION#configure terminal
ORION(config)#router rip
ORION(config-router)#version 2
ORION(config-router)#network 172.16.3.136
ORION(config-router)#network 172.16.3.64
ORION(config-router)#network 172.16.3.0
ORION(config-router)#network 172.16.3.144
ORION(config-router)#CTRL+Z

c. Configuración de RIPv2 para ERA

ERA#configure terminal
ERA(config)#router rip
ERA(config-router)#version 2
ERA(config-router)#network 172.16.3.144
ERA(config-router)#network 172.16.2.0
ERA(config-router)#network 172.16.0.0
ERA(config-router)#network 172.16.3.140
ERA(config-router)#CTRL+Z

5. Verifique de nuevo las tablas de enrutamiento

a. Deje pasar unos segundos para que la red converja y luego revise de nuevo las tablas de
enrutamiento de cada equipo con el comando show ip route. Podrá ver como ahora todos los
routers poseen la misma información sobre la internetwork, ponga atención en las
direcciones de red, ahora salen acompañadas por la máscara de subred.

6. Configure las estaciones de trabajo.

a. PC0: Dirección ip: 172.16.0.2, máscara de subred: 255.255.254.0; gateway: 172.16.0.1


b. PC1: Dirección ip: 172.16.2.2, máscara de subred: 255.255.255.0; gateway: 172.16.2.1
c. PC2: Dirección ip: 172.16.3.2, máscara de subred: 255.255.255.192; gateway: 172.16.3.1
d. PC3: Dirección ip: 172.16.3.66 máscar de subred: 255.255.255.192; gateway: 172.16.3.65
e.PC4: Dirección ip: 172.16.3.130 máscara de subred: 255.255.255.248; gateway:
172.16.3.129
f. PC5: Dirección ip: 172.16.3.150 máscara de subred: 255.255.255.252; gateway:
172.16.3.149

7. Compruebe la conectividad de extremo a extremo.

a. Realice varias pruebas usando las herramientas ping y traceroute (tal y como se
utilizaron en la guía anterior), tanto desde la consola de los routers como desde las
estaciones de trabajo (tracert). Tendrá respuesta desde cualquier dispositivo de la
internetwork.
6 Comunicación de datos II. Guía 3

Configurar los IP Host en los routers.

a. Configurando el router GAUS


GAUS#configure terminal
GAUS(config)#ip host ORION 172.16.3.136
GAUS(config)#ip host ERA 172.16.3.142
GAUS(config)#ip host PC0 172.16.0.2
GAUS(config)#ip host PC1 172.16.2.2
GAUS(config)#ip host PC2 172.16.3.2
GAUS(config)#ip host PC3 172.16.3.66
GAUS(config)#ip host PC4 172.16.3.130
GAUS(config)#ip host PC5 172.16.3.150
GAUS(config)#CTRL+Z

b. Configurando el router ORION


ORION#configure terminal
ORION(config)#ip host GAUS 172.16.3.137
ORION(config)#ip host ERA 172.16.3.145
ORION(config)#ip host PC0 172.16.0.2
ORION(config)#ip host PC1 172.16.2.2
ORION(config)#ip host PC2 172.16.3.2
ORION(config)#ip host PC3 172.16.3.66
ORION(config)#ip host PC4 172.16.3.130
ORION(config)#ip host PC5 172.16.3.150
ORION(config)#CTRL+Z

c. Configurando el router ERA


ERA#configure terminal
ERA(config)#ip host GAUS 172.16.3.141
ERA(config)#ip host ORION 172.16.3.146
ERA(config)#ip host PC0 172.16.0.2
ERA(config)#ip host PC1 172.16.2.2
ERA(config)#ip host PC2 172.16.3.2
ERA(config)#ip host PC3 172.16.3.66
ERA(config)#ip host PC4 172.16.3.130
ERA(config)#ip host PC5 172.16.3.150
ERA(config-router)#CTRL+Z

NOTA: Probar la conectividad con las herramientas ping y traceroute, haciendo uso del
nombre y no de la IP

9. Verificar la configuración de cada uno de los routers y guardarla en la NVRAM.

a. Router GAUS
GAUS#show run
GAUS#copy running-config startup-config

b. Router ORION
ORION#show run
Comunicación de datos II. Guía 3 7

ORION#copy running-config startup-config

c. Router ERA
ERA#show run
ERA#copy running-config startup-config

10. Comprobar el funcionamiento de RIPv2 en los routers

a. Router GAUS
GAUS#show ip protocols
GAUS#show ip interfaces FastEthernet 0/0
GAUS#show ip interfaces Serial 0/0
GAUS#show interface

b. Router ORION
ORION#show ip protocols
ORION#show ip interfaces FastEthernet 0/0
ORION#show ip interfaces Serial 0/0
ORION#show ip interfaces Serial 0/1
ORION#show interface

c. Router ERA
ERA#show ip protocols
ERA#show ip interfaces FastEthernet 0/0
ERA#show ip interfaces Serial 0/0
ERA#show interface

11. Aplicar el comando debug para verificar los tiempos de RIPv2

a. Router GAUS
GAUS#debug ip rip events
b. Router ORION
ORION#debug ip rip events
c. Router ERA
ORION#debug ip rip events

OJO: El comando debug utiliza recursos del enrutador para funcionar por lo que no se
recomienda utilizarlo por largos periodos, o en redes de alta productividad, porque puede
ocasionar que el router procese más lento la información.

12. Detener el debug de RIP

a. Router GAUS
GAUS#undebug all
a. Router ORION
ORION#undebug all
a. Router ERA
ERA#undebug all
8 Comunicación de datos II. Guía 3

Redistribución de rutas por defecto.

La redistribución de rutas por defecto es muy útil cuando se tienen topologías muy
complejas y se necesita hacer uso de enrutamiento de este tipo en todos los routers, esto
quiere decir que todos los routers tengan un gateway único en común, para ello sería muy
tedioso y muy poco productivo tener que ir router por router haciendo la configuración. Para
solucionar este problema se hace uso del comando default-information originate desde el
modo router:
Router(config-router)#default-information originate

13. Configurar la ruta por defecto para el router GAUS

GAUS#configure terminal
GAUS(config)#ip route 0.0.0.0 0.0.0.0 172.16.3.150
GAUS(config)#router rip
GAUS(config-router)#default-information originate
GAUS(config-router)#CTRL+Z
GAUS#show ip route

Y veremos que la ruta por defecto se encuentra configurada.

14. Verificar la tabla en los otros dos router

a. GAUS#show ip route
b. ORION#show ip route

15. Hacer pruebas de conectividad para probar la ruta por defecto.

Investigación Complementaria

1. Que pasa con las tablas de enrutamiento de los router si se cae(borra) el enlace
Guía 3
serial entre los router GAUS y ERA?
2. Que
Guía 4 sucede si se vuelve a reestablecer?
3. Que tendríamos que hacer para que el trafico de las redes LAN utilicen únicamente
fía los enlaces de 1024 kbps y tengan el de 128 kbps como un backup?
4. Investigue la diferencia entre subneting y VLSM

Bibliografía

Network+ 2005 In Depth, Tamara Dean; Course Technology PTR; 1 edition (March 15,
Guía 3
2005)
Local Area Networks (McGraw-Hill Forouzan Networking Series), Forouzan McGraw-Hill
Guía 4 - Europe (February 1, 2002)
Education
CCNA Study Guide Fourth Edition, Sybex
fía
Comunicación de datos II. Guía 3 9

Hoja de cotejo: 1
Docente: 1
Guía 1: Enrutamiento dinámico RIP v2
Máquina No:
Tema: Presentación del programa
Alumno: MáquinaGL:
No:

Alumno:
Docente: Máquinaa No: Fecha:
GL:

Docente: GL:

EVALUACION

% 1-4 5-7 8-10 Nota

CONOCIMIENTO Del Conocimiento Conocimiento Conocimiento


20 deficiente y explicación completo y
al de los incompleta de explicación
30% fundamentos los clara de los
teóricos fundamentos fundamentos
teóricos teóricos

APLICACIÓN Del
DEL 40%
CONOCIMIENTO al
60%

ACTITUD
Del No tiene Actitud Tiene actitud
15% actitud propositiva y proactiva y
al proactiva. con sus
30% propuestas no propuestas
aplicables al son
contenido de concretas.
la guía.
TOTAL 100%