Sie sind auf Seite 1von 7

Q6 – IPV6

Phone is not able to ping 2001:BEEF:CAFÉ::26/64 located on Server4. Fix the problem that
the following is successful.

Phone# ping 2001:BEEF:CAFÉ::26


1. Establishing Neighbor
1.1. IPV4 Neighbor
1. Check direct connect
2. Is there an ACL denying TCP port 179 ?

1.2. IPV6 Neighbor


1. Check IPv4 and IPv6 neighbor status
2. If using IPv4 BGP neighbor to transmit IPv6 prefixes, no need to establish IPv6 neighbor

2. Transmit IPv6 routes


2.1. Through IPv6 Neighbor

1. R26 to R22 - Is there a ::26 route on R22


2. R22 to R25
a. Check if the next hop set by route-map in the BGP IPv4 address-family is its on
outbound interface
b. Check if there is a problem with the directly connected network

2.2. Through IPv4 Neighbor


1. R26 to R22 – Is there a ::26 route on R22
2. R22 to R25
a. Check the IPv6 neighbor status first
b. Check whether there is a problem with the directly connected network
ANS Q6 – IPv6
# Device Commands Validations
1 Check BGP Neighbor
Server4 sh ipv6 route connected To copy the IPv6 address of the Server
Phone ping 2001:BEEF:CAFÉ::26
R22 sh bgp ipv6 unicast Only Server network prefix found. No Phone
network prefix (2001:CC1E:BEEF:CAFÉ::26)
R25 sh bgp ipv6 uni sum Check IPv6 peering from R22 to R25
BGP neighbor is Idle
R22 sh bgp ipv6 uni sum BGP neighbor R25 is Idle (Admin) means
shutdown
R22 sh run | s r b Fault 1: Found R25 neighbor shutdown
Fix R22
router bgp 12345
no neighbor 123.1.2.18 shutdown
sh ip bgp ipv6 unicast summary /--BGP neighbors should be up.

R25
sh ip bgp ipv6 unicast summary /--BGP neighbors should be up.

2 Check Route-Map
R22 sh bgp ipv6 uni sum The phone network is advertised. But the
next hop is IPv4 address (::FFFE:123.1.2.18)

R22 sh run | s r b Inside ipv6 address family, IPv4 address was


used to build the neighbor. Also, route-map
is present for the R25 neighbor.
R22 sh run | s route-map No match statement on the route-map
R25 sh run | s r b No route-map present inside the IPv6
address-family
R25 sh run | s route-map Fault 2: Route-map NEXT-HOP was found,
but not used
Fix R25

router bgp 65101


address-family ipv6
neighbor 123.1.2.17 route-map NEXT-HOP out

clear ip bgp * soft


sh bgp ipv6 unicast

R22 sh bgp ipv6 uni sum Fault 3: The next hop address is incorrect
Fix R22
route-map NEXT-HOP permit 10
no set ipv6 next-hop 2001:2::2
set ipv6 next-hop 2001:CC1E:BEEF:2225::17
/--R22 S4/0 ipv6 address. NOTE it is NOT R25 S4/0 ipv6 address
clear ip bgp * soft

R25
route-map NEXT-HOP permit 10
no set ipv6 next-hop 2001:2::3
set ipv6 next-hop 2001:CC1E:BEEF:2225::18
/--R25 S4/0 ipv6 address. NOTE it is NOT R25 S4/0 ipv6 address
clear ip bgp * soft

3 Check Network Statement


R25 sh ipv6 route connected Capture both networks (S4/0 and E0/0) on
sh run | s r b notepad. Both must be advertised via
network statement.
Fault 4: Wrong Network Mask
Fix R25
router bgp 65101
add ipv6
network 2001:CC1E:BEEF::2225/128

4 Test
Phone ping 2001:BEEF:CAFÉ::26 Success

TS1 Q6 – IPv6 Fault Summary and Remediation


# Device Fault Remediation
1 R22 BGP Neighbor 25 no neighbor 123.1.2.18 shutdown
Shutdown
2 R25 Route-Map neighbor 123.1.2.17 route-map NEXT-HOP out
NEXT-HOP
3 R22 Wrong Next-Hop R22
R25 IP set ipv6 next-hop 2001:CC1E:BEEF:2225::17

R25
set ipv6 next-hop 2001:CC1E:BEEF:2225::18

4 R25 Wrong Network network 2001:CC1E:BEEF::2225/128


Mask

Concept
 The BGP neighbor between R25 and R22 is special is it uses IPv4 address to form ipv6
neighbor.
 A route-map with next-hop is needed for prefix advertisement because ipv6 addresses
are used in ipv4 to form bgp neighbor. Without next-hop, the ipv6 address of neighbor
will be unreachable. Hence, ipv6 routes can’t be entered into the routing table.
 next-hop address must be Router’s own ipv6 address of the interface, not neighbor’s
ipv6 interface address. Essentially, the routers use their own IPV6 address as next-hop
to be able to perform ipv6 prefix advertisement.
 Here are outputs from the three commands on R25 and R22. Pay close attention to the
route-map next hop address and the next-hop address from #sh bg ipv6 un
command.
R25#sh bg ipv6 un
BGP table version is 12, local router ID is 202.65.1.5
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 2001:BEEF:CAFE::/64
2001:CC1E:BEEF:2225::17
0 12345 10001 i
*> 2001:CC1E:BEEF:25::/64
:: 0 32768 i
*> 2001:CC1E:BEEF:2225::/64
:: 0 32768 i

R25#sh run int s4/0


interface Serial4/0
ip address 123.1.2.18 255.255.255.252
ipv6 address 2001:CC1E:BEEF:2225::18/64
serial restart-delay 0
end

R25#sh run | s route-m


neighbor 123.1.2.17 route-map NEXT-HOP out
route-map NEXT-HOP permit 10
set ipv6 next-hop 2001:CC1E:BEEF:2225::18

R22#sh bg ipv6 un
BGP table version is 8, local router ID is 134.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


*> 2001:BEEF:CAFE::/64
2001:CC1E:ABCD:2622::12
0 10001 i
*> 2001:CC1E:BEEF:25::/64
2001:CC1E:BEEF:2225::18
0 0 65101 i
r> 2001:CC1E:BEEF:2225::/64
2001:CC1E:BEEF:2225::18
0 0 65101 i
R22#sh run int S4/0
interface Serial4/0
ip address 123.1.2.17 255.255.255.252
ipv6 address 2001:CC1E:BEEF:2225::17/64
ipv6 traffic-filter BGP out
serial restart-delay 0
end

R22#sh run | s route-m


neighbor 123.1.2.18 route-map NEXT-HOP out
route-map NEXT-HOP permit 10
set ipv6 next-hop 2001:CC1E:BEEF:2225::17

 The following screenshot shows the incorrect network mask in BGP configuration of R25
High Level Steps

 Check bgp neighbor


 Check next-hop
 Check Network

Das könnte Ihnen auch gefallen