Sie sind auf Seite 1von 12

El siguiente es un pequeño resumen sobre comandos para configurar un switch cisco y

algunos de router, espero que les sea útil como lo es para mi.

Rip
NewYork(config)#interface fastethernet0/0
NewYork(config-if)#ip address 192.168.50.129 255.255.255.192
NewYork(config-if)#ip rip send version 1
NewYork(config-if)#ip rip receive version 1
NewYork(config)#interface fastethernet0/1
NewYork(config-if)#ip address 172.25.150.193 255.255.255.240
NewYork(config-if)#ip rip send version 1 2

Show ip protocols
show interface interface
show ip interface interface
show running-config
Show ip rip database
OSPF
Router(config)#router ospf process-id
Router(config-router)#network address wildcard-mask area area-id

Router(config)#interface lookback 0
Router(config-if)#ip address 192.168.3.33 255.255.255.255

Rtr(config-if)# bandwidth 64
Rtr(config-if)# ip ospf cost 1562

Autenticación sin md5


Router(config-if)#ip ospf authentication-key password
Router(config-router)#area area-number authentication

Autenticación con md5


Router(config-if)#ip ospf message-digest-key key-id encryption-type md5 key
Router(config-router)#area area-id authentication message-digest

Router(config-if)#ip ospf hello-interval seconds


Router(config-if)#ip ospf dead-interval seconds
debug ip ospf events
--aumentar la prioridad para elegir un router DR
sw(config)#interface fasethernet 0/0
sw(config-if)#ip osfp priority 50
sw(config-if)#end

EIGRP

Router(config)#router eigrp as-id


Router(config-router)#network 192.168.3.0
Router(config-router)#end
Router# show ip eigrp topology

eigrp log-neighbor-changes
resumen de rutas: router(config-router)#no auto-summary

Switch

Switch# dir flash:


Switch#show flash
Switch#show vlan

Switch#vlan database
Switch(vlan)#vlan vlan_number
Switch(vlan)#exit
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan vlan_number
Switch#vlan database
Switch(vlan)#no vlan 300
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan vlan_number

Sw1#delete flash:vlan.dat
Sw1#erase startup-config
Sw1#reload

Interface web
Sw1(config)#ip http port 80

Ver la tabla MAC:


Switch#show mac-address-table (? Mas opciones)
Switch#clear mac-address-table

Asignar una mac estatica

•Switch(config)#mac-address-table static interface FastEthernet vlan


•Switch(config)#no mac-address-table static interface FastEthernet vlan
Seguridad de Puerto

Sw1(config)#interface fastETehernet 0/2


Sw1(config-if)#switchport port-security ?(sale las opciones)

Limitar la cantidad de host por puerto


1900:
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#port secure mas-mac-count 1
2950:
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#switchport port-security maximum 1

Configuracion del Puerto que se desconecte cuando se produce una violacion de


seguridad

Sw(config-if)#switchport port-security violation shutdown

2900xl:
Sw(config-if)#port security action shutdown

Poner Ip a la Vlan1

Catalyst 2950
Sw(config)#interface Vlan1
Sw(config-if)#ip address 192.168.1.2 255.255.255.0
Sw(config-if)#no shutdown

Sw(config)# ip default-gateway 192.168.1.1

Catalyst 1900
Sw(config)#ip address 192.168.1.2 255.255.255.0

Sw(config)# ip default-gateway 192.168.1.1

Archivos de configuracion

Sw# copy running-config startup-config

1900:
Sw#copy nvram tftp://tftp server ip add/destination_filename

COnfiguracion de la velocidad

Switch(config)#interface fastethernet 0/9


Switch(config-if)#duplex full
Switch(config-if)#speed 100

Crear el trunk del switch

Sw(config)#interface fastethernet 0/1


Sw(config-if)#swicthport mode trunk
Sw(config-if)#end
2900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end

1900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end

Trunk en el router

Router(config)#interface fastethernet 0/0


Router(config-if)#no shutdown
Router(config-if)#interface fastEthernet 0/0.1
Router(config-subif)#encapsulation dot1q vlan-number
Router(config-subif)#ip address…….

router1#copy running-config tftp

Quitar un Puerto de una VLAN


Switch(config)#interface fasethernet 0/9
Switch(config-if)#no switchport access vlan 300

Eliminar una vlan

Switch#vlan database
Switch(vlan)#no vlan 300

Spanning tree
show spanning-tree

Configuracion de VTP
switch#vlan database
switch#vtp v2-mode

switch(vlan)#vtp domain password

switch#vtp {client | server | transparent}

Copiar el IOS a un server tftp

Sw#copy flash tftp


2900: sw#copy flash:nombre_del_archivo tftp

Copiar IOS desde un Server tftp


Sw#copy TFTP flash

Sw# copy Start tftp

1900: sw#copy nvram tftp://numero-ip/name

Sw#copy tftp startup-config

1900: sw#copy tftp://numero-ip/name nvram

Recuperar el acceso al switch

1. Apagar el switch, Vuelva a encenderlo mientras presiona el boton MODE en la parte


delantera del switch. Deje de presionar el boton MODE una vez que se apague el led de
STAT
2. introducir los siguientes comandos:
flash_init
load_helper
dir flash:
3. rename flash:config.text flash:config.old
4. reiniciar el sistema original:
4.1 despues de entrar al switch hacer: rename flash:config.old flash:config.text
4.2 sw#copy flash:config.text system:running-config
4.3 Cambiar los password

Actualizar el firmware

Sw#show boot (muestra el archive de boteo)

Cambiar el nombre del archivo de la ios,con el commando #rename flash:nombre


flash:Nuevo_nombre

Sw(config)#no ip http Server


Sw# delete flash:html/*

Extraer la nueva version del IOS

Sw#archive tar /x tftp://192.168.1.3/nombre_del_archivo.tar flash:


Sw(config)#ip http Server
Sw(config)#boot system flash:nombre.bin

Spanning-Tree

#show spanning-tree brief


Cambiar prioridad: ios 12.0 sw(config)#spanning-tree priority 1
sw(config)#exit

ios 12.1 sw(config)#spanning-tree vlan 1 priority 4096


sw(config)#exit

Configurar VLAN

Sw#vlan database
Sw(vlan)#vlan 2 name Logistica
Sw(vlan)#vlan 3 name Licitaciones
Sw(vlan)#end

1900:
Sw#config terminal
Sw(config)#vlan 2 name VLAN2
Sw(config)#vlan 3 name VLAN3

Configurar puertos en las VLAN

Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#switchport mode access
Sw(config-if)#switchport access vlan2
Sw(config-if)#end

Elminar el Puerto de la vlan


Sw(config-if)#no switchport access vlan2
Sw(config-if)#end

1900:
Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#vlan static 2

Para eliminar un Puerto de la vlan


Sw(config-if)#no vlan-membership 2

Sw#show vlan
Sw#show vlan id 2

1900: Show vlan-membership


Show vlan 2

Eliminar un vlan

Sw#valn database
Sw(vlan)#no vlan 3
Sw(vlan)# exit
1900: sw(confgi)# interface ethernet 0/7
sw(confgi)#no vlan 3

enlacen troncal ISL

sw(Config.)#interafce fastethernet 0/1


sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation isl
sw(Config-if)#end
enlace troncal 802.1q

2950: por defecto dotiq


sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk

2900:
sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation dot1q

Vtp , servidor y cliente

Sw# Vlan database


Sw(vlan)# vtp server
Sw(vlan)# vtp domain group1
Sw(vlan)# exit

Sw# Vlan database


Sw(vlan)# vtp client
Sw(vlan)# vtp domain group1
Sw(vlan)# exit

Ruteo entre VLAN

Poner el encapsulamiento en las subinterfaces del router

(config-if)#interface fastethernet 0/0.1


(config-subif)#encapsulation dot1q 1 (1 es la vlan a la que esta
Cisco#show ver
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(7), RELEASE SOF
TWARE (fc6)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Tue 28-Feb-06 21:03 by alnguyen

ROM: System Bootstrap, Version 12.3(8r)T9, RELEASE SOFTWARE (fc1)

Cisco uptime is 0 minutes


System returned to ROM by reload at 04:39:18 GMT Sun May 31 2009
System image file is "flash:c1841-ipbase-mz.124-7.bin"

Cisco 1841 (revision 6.0) with 114688K/16384K bytes of memory.


Processor board ID FTX1015W202
2 FastEthernet interfaces
2 Serial(sync/async) interfaces
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
31360K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Cisco#show running-config
Building configuration...

Current configuration : 1311 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$tMHY$wb5dOqoX3iRYMBRpbycb0/
enable password 7 1500135C51203B283C
!
no aaa new-model
!
resource policy
!
clock timezone GMT -3
ip cef
!
!
!
!
ip name-server 192.168.0.10
ip name-server 200.42.97.110
username c4004 privilege 15 password 7 01011E540E01160335
!
!
!
interface FastEthernet0/0
description WAN INTERFACE
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description LAN INTERFACE
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
router rip
network 192.168.0.0
network 192.168.1.0
!
ip default-gateway 192.168.1.1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 192.168.0.0 255.255.255.0 FastEthernet0/1
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
!
no ip http server
!
!
control-plane
!

line con 0
password 7 105C1149501D020718
login
line aux 0
line vty 0 4
password 7 071D391C1B03090903
login local
!
scheduler allocate 20000 1000
end

Cisco#

Cisco#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 192.168.0.0/24 is directly connected, FastEthernet0/1


C 192.168.1.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 is directly connected, FastEthernet0/0

Cisco#

NAT ESTÁTICO
La IP pública que nos otorga nuestro ISP es únicamente la 161.196.198.145
255.255.255.248

Configuración:
Compania(config)#ip nat inside source static 192.168.1.254 194.194.194.5

(Se configura el tipo de NAT como estático y le decimos que IP privada va a ser
cambiada a la IP pública)

Compania(config)#int fa0/0

(Aplicamos en la interfaz de entrada en este caso la LAN)

Compania(config-if)# ip nat inside

(Se Aplica para lo que entre a la interfaz sea cambiado)

Compania(config-if)#int s0/0

(Aplicamos en la interfaz de Salida en este caso la Serial)

Compania(config-if)#ip nat outside

(Se Aplica para lo que Nat Salga por esta Interfaz)

Compania(config-if)#end

(Para salir el mode privilegiado)

Compania# write memory

(Se guarda la Configuración)

NAT DINÁMICO
La Network públicas que nos otorga nuestro ISP es 161.196.198.140
255.255.255.248 con un rango de IPS disponible 161.196.198.145 -
161.196.198.146

Configuración:

Compania(config)#ip nat pool NAVEGACION 194.194.194.1 194.194.194.6 netmask


255.255.255.248

(Creamos un pool con las direcciones públicas y la damos un nombre en este caso
NAVEGACION)

Compania(config)#access-list 1 permit 192.168.1.0 0.0.0.255

(Creamos una access-list para hacer un filtro de las IPS privadas que podrán
Cambiarse a las públicas)

Compania(config)#ip nat inside source list 1 pool NAVEGACIÓN OVERLOAD

(Indicamos el rango de las IP privadas que se filtro con la access-list que van a
hacer cambiadas a las IP públicas del pool NAVEGACIÓN. La opción OVERLOAD nos
permite que todos los hosts se asignen a una sóla ip por diferentes Puertos no
utilizando la siguiente ip del pool hasta que no se agote la primera)

Compania(config)#int fa0/0

(Aplicamos en la interfaz de entrada en este caso la LAN)

Compania(config-if)# ip nat inside

(Se Aplica para lo que entre a la interfaz sea cambiado)

Compania(config-if)#int s0/0

(Aplicamos en la interfaz de Salida en este caso la Serial)

Compania(config-if)#ip nat outside

(Se Aplica para lo que Nat Salga por esta Interfaz)

Compania(config-if)#end

(Para salir el mode privilegiado)

Compania# write memory

(Se guarda la Configuración)

Comandos para verificación de la tabla NAT

show ip nat translations

(Para mostrar las traducciones activa)

show ip nat statistics


(Para mostrar las traducciones estáticas activa)

show ip nat translations verbose

(Muestra información adicional para cada entrada en la tabla de traducción,


incluyendo cómo hace mucho tiempo la entrada se ha creado y utilizado)

debug ip nat