Sie sind auf Seite 1von 6

PRECISO DE UMA AJUDA COM ESSE ALGORITMO, FEITO NO VISUALG. PRECISO CLASSIFICAR ELE !!!

! // Funo : // Autor : // Data : 29/11/2010 // Seo de Declaraes var i : inteiro j : inteiro l : vetor[1..10] de caractere c : vetor[1..7] de caractere agenda :vetor[1..2,1..7]de caractere x : caractere inicio para i de 1 ate 10 passo 1 faca para j de 1 ate 7 passo 1 faca escreval("nome: ") leia (agenda[i,1]) escreval("endereo: ") leia (agenda[i,2]) escreval("CEP: ") leia (agenda[i,3]) escreval("cidade: ") leia (agenda[i,4]) escreval("estado: ") leia (agenda[i,5]) escreval("fone: ") leia (agenda[i,6]) escreval("E-mail: ") leia (agenda[i,7]) fimpara para i de 1 ate 10 passo 1 faca para j de 1 ate 7 passo 1 faca escreval(agenda[i,j]) fimpara fimpara para i de 1 ate 10 passo 1 faca para j de i+1 ate 7 passo 1 faca se agenda > agenda[j] entao x<- agenda agenda <- agenda[j]

agenda[j] <- x fimse fimpara fimpara fimpara // Seo de Comandos fimalgoritmo AJUDA AI GENTE TA DANDO UMA DOR DE CABEA PRA MIM !!! precisa classificar pelo nome

EXERCCIOS 4. Elabore um algoritmo que permita ler 6 notas de alunos de uma turma e os respectivos nomes, identifique qual a nota mxima e a mnima e mostre quais os respectivos nomes dos alunos que as obtiveram.

var nota: vetor[1..6] de real nome: vetor[1..6] de caractere max,min: real i: inteiro inicio max <- 0 min <- 10 Para i de 1 ate 6 faca Escreval("Digite o nome do(a) aluno(a) ",i, ".") Leia(nome[i]) Escreval("Digite a nota do(a) ", nome[i], ".") Leia(nota[i]) se (nota[i]>max) entao max <- nota[i] fimse se (nota[i]<min) entao min <- nota[i] fimse fimpara limpatela Escreva("Nota mxima: ", max) para i de 1 ate 6 faca se (nota[i]=max) entao Escreval(". Aluno: ", nome[i]) fimse fimpara Escreva("Nota mnima: ", min) para i de 1 ate 6 faca se (nota[i]=min) entao Escreval(". Aluno: ", nome[i]) fimse

fimpara fimalgoritmo
8. Leia 20 nmeros do teclado e coloque em um vetor. Depois mostre os nmeros pares e suas respectivas posies no vetor.

algoritmo "semnome" var A: vetor[1..20] de inteiro i: inteiro inicio Para i de 1 ate 20 faca Escreval("Digite o nmero para a posio ", i) Leia(A[i]) fimpara limpatela Escreval("Nmeros Pares:") Para i de 1 ate 20 faca Se ( (A[i] mod 2)=0 ) entao Escreval(A[i], " - Posio ", i) fimse fimpara fimalgoritmo

12. Escreva um algoritmo que leia um vetor de tamanho n (informado pelo usurio) e escreva a soma de todos os elementos de ndice par.

algoritmo "semnome" var A: vetor[1..400] de inteiro n,i,soma: inteiro inicio Escreval("Digite o tamanho do vetor (Max: 400):") Leia(n) Para i de 1 ate n faca Escreval("Digite o nmero da posio ", i, ".") Leia(A[i]) fimpara Para i de 1 ate n faca se ((i mod 2)=0) entao soma <- soma + A[i] fimse fimpara Escreval("A soma : ", soma, ".")

16. Ler do teclado 12 nmeros inteiros e armazen-lossimmmmmm em um vetor N. Em seguida, copiar os elementos pares para o vetor X e os mpares para o vetor Y. algoritmo "semnome" var

N: vetor[1..12] de inteiro X: vetor[1..12] de inteiro Y: vetor[1..12] de inteiro a,b,i: inteiro inicio a <- 1 b <- 1 Para i de 1 ate 12 faca Escreval("Digite o nmero da posio ", i, ".") Leia(N[i]) fimpara Para i de 1 ate 12 faca se ((i mod 2)=0) entao X[a] <- N[i] a <- a + 1 senao Y[b] <- N[i] b <- b + 1 fimse fimpara fimalgoritmo