Sie sind auf Seite 1von 4

algoritmo "Menu de multiclassificao de um vetor" // Funo : Exercer varias funes para um vetor // Autor : Anderson A.

Rezende // Data : 15/4/2009 // fazer um menu de funes var vet,vetre:vetor[1..99]de inteiro I,J,n,x,b,p,val,m:inteiro med,x3,x2:real a : caracter procedimento atribuicaovalor inicio escreval("Atribuio de valores ao vetor") I:=0 n:=0 escreval("Entre com o valor : ") escreval("Digite 99 para finalizar o vetor") leia(b) enquanto (b <> 99) faca I:=I+1 vet[I]:=b vetre[I]:=b n:=n+1 escreval("Entre com o valor : ") leia(b) fimenquanto fimprocedimento procedimento classificacrescen inicio para I de 1 ate (n-1) passo 1 faca para J de (I+1) ate n passo 1 faca se (vet[I] > vet[J]) entao x<-vet[I] vet[I]<-vet[J] vet[J]<-x fimse fimpara fimpara escreval("Classificao do vetor em ordem crescente:") para I de 1 ate n passo 1 faca escreval(vet[I]) fimpara escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento classificadecrescen inicio para I de 1 ate (n-1) passo 1 faca para J de (I+1) ate n passo 1 faca se (vet[I] < vet[J]) entao x<-vet[I] vet[I]<-vet[J] vet[J]<-x fimse fimpara fimpara escreval("Classificao do vetor em ordem decrescente:") para I de 1 ate n passo 1 faca escreval(vet[I]) fimpara escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento exibirmaiormenor

inicio para I de 1 ate (n-1) passo 1 faca para J de (I+1) ate n passo 1 faca se (vet[I] > vet[J]) entao x<-vet[I] vet[I]<-vet[J] vet[J]<-x fimse fimpara fimpara escreval("O maior valor anexado no vetor = ",vet[1]) escreval("O menor valor anexado no vetor = ",vet[n]) escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento quadradoxp inicio//quadrado da segunda e terceira posio do vetor x2:=vetre[2]^2 x3:=vetre[3]^2 escreval("O valor da segunda posio do vetor ao quadrado = ",x2) escreval("O valor da terceira posio do vetor ao quadrado = ",x3) escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento imprimirconteudo inicio escreval("Veja o contedo de certa posio do vetor!") repita escreval("Digite a posio:") leia(p) escreval("O valor anexado nessa posio =", vetre[p]) escreval("Digite 1 para visualisar outro contedo ou 0 para voltar ao menu;") leia(a) ate (a=0) fimprocedimento procedimento imprimirposicao inicio escreval("Veja qual o posio se encontra certo valor!") escreval("Digite o valor para saber qual a posio:") leia(val) para I de 1 ate n faca se (val = vetre[I]) entao escreval("Esse valor se encontra no vetor ",I) fimse fimpara escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento calcularmedia inicio x<-0 para I de 1 ate n faca x:=x+vet[I] fimpara med:=x/n escreval("Mdia dos valores do vetor = ",med) escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento inverteroriginal inicio escreval("Vetor original invertido:") para I de n ate 1 passo -1 faca escreval("Vet[",I,"]=",vetre[I])

fimpara escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento eliminarelemento//inacabado inicio I:=0 escreval("Elimine um elemento do vetor") escreval("Digite o nmero do vetor a ser eliminado") leia(I) se (I <= 0) e (I >= n) entao escreval("O vetor a ser eliminado no existe!") senao vetre[I]:=0 vet[I]:=0 escreval("O valor do vetor[",I,"] = ",vetre[I]) fimse escreval("Digite 0 para voltar ao menu") leia(a) fimprocedimento procedimento buscabin var ini, fin, busca, enc, sair, meio : inteiro inicio para I de 1 ate (n-1) passo 1 faca//etapa de classificao crescente para J de (I+1) ate n passo 1 faca se (vet[I] > vet[J]) entao x<-vet[I] vet[I]<-vet[J] vet[J]<-x fimse fimpara fimpara//final da etapa sair:=0 escreval("Busca Binria") escreval("Digite o valor do elemento a ser encontrado:") leia(busca) ini := 1 fin := n enquanto ((ini <= fin) e (sair=0)) faca meio:=(ini + fin) div 2 se (vet[meio] = busca) entao sair := 1 enc := 1 senao se busca < vet[meio] entao fin := meio -1 senao ini := meio +1 fimse fimse fimenquanto se sair = 1 entao escreval("O valor", busca, " esta na posio vetor[" , meio, "]") senao escreval("Cod = ", busca, "no existe no vetor") fimse escreval("Imprime Vetor") para I de 1 ate n faca escreval (vet[I]) fimpara escreval("Tecle enter para voltar ao menu")

leia(a) fimprocedimento INICIO repita limpatela escreval("MENU:") escreval("Digite 1 p/ carregar o vetor") escreval("Digite 2 p/ classificar o vetor em ordem crescente") escreval("Digite 3 p/ classificar o vetor em ordem decrescente") escreval("Digite 4 p/ para verificar o maior e o menor valor do vetor") escreval("Digite 5 p/ imprimir na tela a 1 e a 2 posio do vetor ao quadrado") escreval("Digite 6 p/ imprimir o valor na tela, a patir da posio") escreval("Digite 7 p/ imprimir na tela a posio, a partir do valor") escreval("Digite 8 p/ calcular e imprimir na tela a mdia aritm. do vetor") escreval("Digite 9 p/ imprimir na tela vetor original invertido") escreval("Digite 10 p/ localizar a posio de algum valor do vetor") escreval("Digite 0 p/ encerrar o programa") leia(m) se m=1 entao atribuicaovalor senao se m=2 entao classificacrescen senao se m=3 entao classificadecrescen senao se m=4 entao exibirmaiormenor senao se m=5 entao quadradoxp senao se m=6 entao imprimirconteudo senao se m=7 entao imprimirposicao senao se m=8 entao calcularmedia senao se m=9 entao inverteroriginal senao se m=10 entao buscabin //eliminarelemento refazer procedimento fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse ate(m=0) fimalgoritmo