Sie sind auf Seite 1von 13

[SOLVED] problem in installing ns2.33 in ubuntu 8.

10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

Did you know LQ has a Linux Hardware Compatibility List?

Home

Forums

HCL

Reviews

Tutorials

Articles

Register

Search Remember Me?

Main Menu

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

User Name Password

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Welcome to LinuxQuestions.org, a friendly and active Linux Community. You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today! Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. Are you new to LinuxQuestions.org? Visit the following links: Site Howto | Site FAQ | Sitemap | Register Now If you have any problems with the registration process or your account login, please contact us. If you need to reset your password, click here. Having a problem logging in? Please visit this page to clear all LQ-related cookies.
Page 1 of 2 1 2 > LinkBack 09-08-2009, 11:14 AM Search this Thread #1 problem in installing ns2.33 in ubuntu 8.10

Linux Forums Android Forum Search LQ Tags Linux HCL Linux Tutorials LQ Job Marketplace Linux Wiki Distro Reviews Book Reviews Download Linux Social Groups LQ Blogs Home (Con't)

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Rep:

I am using UBUNTU8.10 via VMware in windows vista os. i had installed ns2.33 in this way $ tar -xzvf ns-allinone-2.33.tar.gz $ cd ns-allinone-2.33

1 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

Sponsored $ sudo apt-get Linux Operating System install buildDeb File essential autoconf Debian Sarge

UNIX Systems Administrator Debian Package Linux Kernel UNIX OS

[Log in to get rid of this advertisement] automake libxmu-dev or $ sudo apt-get install -f build-essential libxt-dev libxt6 \ libsm-dev libsm6 libice-dev libice6 libxmu-dev $./install Set environment variables $ gedit ~/.bashrc $ source ~/.bashrc ######## now problem is this when i try to run the software $ ns then error comes :"The program 'ns' is currently not installed. You can install it by typing: sudo apt-get install host bash: ns: command not found" ######## during Validation $ cd ns-2.32 $ ./validate error comes :file not found some tests failed.
My LQ

Login Register
Write for LQ

09-08-2009, 11:22 AM

#2 Quote:

repo
LQ 5k Club Registered: May 2001 Location: Belgium Distribution: Slackware current Posts: 7,856 Rep:

$./install Does install give you error messages?

LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu

LQ Calendar LQ Rules LQ Sitemap Site FAQ View New Posts

2 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

09-08-2009, 11:59 AM

#3

knudfl
LQ 5k Club Registered: Jan 2008 Location: Copenhagen, DK Distribution: pclos2010.12, Slack13.1 Deb Squeeze +40+ others, for test only. Posts: 7,803 Rep:

Welcome to LQ. Did you check ' .bashrc ' to see, if the new path's have been set ? About ./validate : 1) cd ns-allinone-2.33/ns-2.33 2) ./validate Getting the libraries into the system LIBRARY_PATH in an easy way : sudo apt-get install tcl8.4 tk8.4 and : cd ns-allinone-2.33/otcl-1.13 sudo make install cd ../tclcl-1.19 sudo make install exit ..... ns + nam in the system PATH : cd ns-allinone-2.33/ns-2.33 sudo make install cd ../nam-1.13 sudo make install ... which will copy the two files ns, nam only, to /usr/local/bin/ Good luck ! .....
Last edited by knudfl; 09-08-2009 at 01:23 PM.

View Latest Posts Zero Reply Threads LQ Wiki Most Wanted Jeremy's Blog Report LQ Bug
Syndicate

Latest Threads LQ News


Twitter: @linuxquestions identi.ca: @linuxquestions Facebook: @linuxquestions

09-08-2009, 09:15 PM

#4

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Original Poster Rep:

when i use this command sudo apt-get install build-essential autoconf automake libxmu-dev then an error comes "Couldn't find build-essential package".

09-08-2009, 10:07 PM

#5 ./install errors Quote:

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Original Poster Rep:

Originally Posted by repo Does install give you error messages? yes sir ... ./install gives a huge bunch of errors like this .... /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/..

3 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

/generic/tk3d.c:1301: error: TkDisplay has no member named borderTable /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1301: error: TkDisplay has no member named borderTable /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1306: error: TkBorder has no member named nextPtr /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1307: error: Tk_FakeWin has no member named display /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1307: error: Tk_FakeWin has no member named screenNum /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1307: error: TkBorder has no member named screen /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1308: error: Tk_FakeWin has no member named atts /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1308: error: TkBorder has no member named colormap /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1311: error: TkBorder has no member named objRefCount /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c: In function TkDebugBorder: /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1391: error: TkWindow has no member named dispPtr /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1394: error: TkDisplay has no member named borderTable /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1394: error: TkDisplay has no member named borderTable /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1400: error: TkBorder has no member named nextPtr /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1403: error: TkBorder has no member named resourceRefCount /home/neeraj/Ns/ns-allinone-2.33/tk8.4.18/unix/.. /generic/tk3d.c:1405: error: TkBorder has no member named objRefCount make: *** [tk3d.o] Error 1 tk8.4.18 make failed! Exiting ...

09-08-2009, 11:51 PM

#6

knudfl

Well, build-essential is a rather short list of packages, which you probably already have ... + the Registered: Jan 2008 dependencies .. Location: Copenhagen, DK which are : Distribution: pclos2010.12, Slack13.1 Deb Squeeze +40+ sudo apt-get install dpkg-dev g++ libc6-dev make
LQ 5k Club others, for test only.

4 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

Posts: 7,803 Rep:

These are also needed for ns2 : sudo apt-get install libx11-dev libxmu-dev libxmuheaders libxt-dev libtool Then ... may be ... you can do ' ./install ' ( I can see, it worked OK on my Ubuntu 8.10 , December 2008.) .....
Last edited by knudfl; 09-09-2009 at 12:10 AM.

09-09-2009, 02:22 AM

#7

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Original Poster Rep:

thank you sir but when i use this command : sudo apt-get install dpkg-dev g++ libc6-dev make i get following msges :"Reading package lists... Done Building dependency tree Reading state information... Done Package dpkg-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package dpkg-dev has no installation candidate" and when i use this sudo apt-get install libx11-dev libxmu-dev libxmuheaders libxt-dev libtool

then Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find package libx11-dev

09-09-2009, 03:09 AM

#8

knudfl
LQ 5k Club Registered: Jan 2008 Location: Copenhagen, DK Distribution: pclos2010.12, Slack13.1 Deb Squeeze +40+ others, for test only. Posts: 7,803 Rep:

'dpkg-dev' is not important, just mentioned as part of what you get with 'build-essential'. But 'libx11-dev' is a must. ( And so are libxmu-dev libxmu-headers libxt-dev libtool ). May be have a look in (Menu) System > Administration > Software Sources ... and tick the entries in 'Ubuntu Software', 'Updates', 'Third-Party Software' ( source code isn't needed.)

5 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

... next : sudo apt-get update ... and then you should be able to fetch all packages with sudo apt-get install ..... If you still have problems then : Please show your file /etc/apt/sources.list ( Can be attached as sources.list.txt using the paper clip tool in 'Post Reply'.) .....

09-09-2009, 03:30 AM

#9

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Original Poster Rep:

sources.list file -

deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted # See http://help.ubuntu.com/community /UpgradeNotes for how to upgrade to # newer versions of the distribution. deb http://in.archive.ubuntu.com/ubuntu/ intrepid main restricted deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid main restricted ## Major bug fix updates produced after the final release of the ## distribution. deb http://in.archive.ubuntu.com/ubuntu/ intrepidupdates main restricted deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team. Also, please note that software in universe WILL NOT receive any ## review or updates from the Ubuntu security team. deb http://in.archive.ubuntu.com/ubuntu/ intrepid universe deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid universe deb http://in.archive.ubuntu.com/ubuntu/ intrepidupdates universe deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-updates universe ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team, and may not be under a free licence. Please satisfy yourself as to ## your rights to use the software. Also, please note that software in ## multiverse WILL NOT receive any review or

6 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

updates from the Ubuntu ## security team. deb http://in.archive.ubuntu.com/ubuntu/ intrepid multiverse deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid multiverse deb http://in.archive.ubuntu.com/ubuntu/ intrepidupdates multiverse deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse ## Uncomment the following two lines to add software from the 'backports' ## repository. ## N.B. software from this repository may not have been tested as ## extensively as that contained in the main release, although it includes ## newer versions of some applications which may provide useful features. ## Also, please note that software in backports WILL NOT receive any review ## or updates from the Ubuntu security team. # deb http://in.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse # deb-src http://in.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse ## Uncomment the following two lines to add software from Canonical's ## 'partner' repository. This software is not part of Ubuntu, but is ## offered by Canonical and the respective vendors as a service to Ubuntu ## users. deb http://archive.canonical.com/ubuntu intrepid partner deb-src http://archive.canonical.com/ubuntu intrepid partner deb http://security.ubuntu.com/ubuntu intrepidsecurity main restricted deb-src http://security.ubuntu.com/ubuntu intrepidsecurity main restricted deb http://security.ubuntu.com/ubuntu intrepidsecurity universe deb-src http://security.ubuntu.com/ubuntu intrepidsecurity universe deb http://security.ubuntu.com/ubuntu intrepidsecurity multiverse

09-09-2009, 04:59 PM

#10

knudfl
LQ 5k Club

Please have a look in "Synaptic" > > Properties > Archives > "Software Sources"

7 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

Registered: Jan 2008 Location: Copenhagen, DK Distribution: pclos2010.12, Slack13.1 Deb Squeeze +40+ others, for test only. Posts: 7,803 Rep:

The preferred "Download from" can be changed in > > "Software Sources" May be something wrong with http://in.archive.ubuntu.com/ubuntu/ Distance is usually a minor issue. I often use a German or American mirror. .....

09-10-2009, 05:05 AM

#11

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Original Poster Rep:

After updating when i use following command: "sudo apt-get install build-essential autoconf automake libxmu-dev" then execution of command as follows "The following packages will be upgraded: cpp-4.3 gcc-4.3 gcc-4.3-base libgcc1 libgomp1 libstdc++6 libx11-6 7 upgraded, 29 newly installed, 0 to remove and 260 not upgraded. Need to get 17.4MB/17.5MB of archives. After this operation, 34.3MB of additional disk space will be used. Do you want to continue [Y/n]? y WARNING: The following packages cannot be authenticated! x11proto-core-dev libice-dev libsm-dev libx11-6 libxau-dev libxdmcp-dev x11proto-xext-dev libxext-dev libxi-dev x11protoinput-dev x11proto-kb-dev xtrans-dev libpthread-stubs0 libpthread-stubs0-dev libxcb1-dev libxcb-xlib0-dev libx11-dev libxmu-headers libxt-dev gcc-4.3-base libstdc++6 libgomp1 cpp-4.3 gcc-4.3 libgcc1 m4 autoconf autotools-dev automake libstdc++6-4.3-dev g++-4.3 dpkg-dev libxmu-dev"

then one time it ask "Install these packages without verification [y/N]?" when i answered "n" then "E: Some packages could not be authenticated" and when i answered "y" then

8 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

Media change: please insert the disc labeled 'Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)' in the drive '/cdrom/' and press enter Get:1 http://us.archive.ubuntu.com intrepidupdates/main x11proto-core-dev 7.0.12-1ubuntu0.1 [90.3kB] Get:2 http://us.archive.ubuntu.com intrepid/main libice-dev 2:1.0.4-1 [56.0kB] Get:3 http://us.archive.ubuntu.com intrepid/main libsm-dev 2:1.0.3-2 [24.9kB] Get:4 http://us.archive.ubuntu.com intrepidupdates/main libx11-6 2:1.1.5-2ubuntu1.1 [622kB] Get:5 http://us.archive.ubuntu.com intrepid/main libxau-dev 1:1.0.3-3 [15.6kB] Get:6 http://us.archive.ubuntu.com intrepid/main libxdmcp-dev 1:1.0.2-3 [20.0kB] Get:7 http://us.archive.ubuntu.com intrepid/main x11proto-xext-dev 7.0.2-6build1 [42.5kB] Get:8 http://us.archive.ubuntu.com intrepid/main libxext-dev 2:1.0.4-1 [84.2kB] Get:9 http://us.archive.ubuntu.com intrepid/main libxi-dev 2:1.1.3-2build1 [78.7kB] Media change: please insert the disc labeled 'Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)' in the drive '/cdrom/' and press enter

these msges i got? ? now please tell me what should i do??

09-10-2009, 08:58 AM

#12

knudfl
LQ 5k Club Registered: Jan 2008 Location: Copenhagen, DK Distribution: pclos2010.12, Slack13.1 Deb Squeeze +40+ others, for test only. Posts: 7,803 Rep:

Everything OK, please answer y for yes. If your cd isn't recognized, or is a live version, or you do not want to use it, just uncomment 'media' in "Software Sources" . Or delete or uncomment ( # ) this line in your file, ref. post #9 :
Code:

# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (

09-11-2009, 07:24 AM

#13 Quote:

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Original Poster Rep:

Originally Posted by knudfl /etc/apt/sources.list


Code:

9 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release

when i try to do so .. then it refused to save. "Could not save the file /etc/apt/sources.list. You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again." now what should i do ?? one thing more .. is i need to install package named "libx11-dev" ?? when tried following commands then .. "sudo apt-get install dpkg-dev g++ libc6-dev make" error comes .. "Package dpkg-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source" and "sudo apt-get install libx11-dev libxmu-dev libxmuheaders libxt-dev libtool" error comes... Package libx11-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package libx11-dev has no installation candidate

"sudo apt-get install libxmu-dev" error comes... Reading package lists... Done Building dependency tree Reading state information... Done Package libxmu-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package libxmu-dev has no installation candidate

10 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

now i think packages "libx11-dev" , "libxmu-dev" and "dpkg-dev" are not available.. now give me the link or download location from which i could able to download these packages. or tell me any other way to get them. because from software sources or update manager i was unable to get them. thank you sir..

09-11-2009, 09:06 AM

#14

knudfl
LQ 5k Club Registered: Jan 2008 Location: Copenhagen, DK Distribution: pclos2010.12, Slack13.1 Deb Squeeze +40+ others, for test only. Posts: 7,803 Rep:

Repeat : If your cd isn't recognized, or is a live version, or you do not want to use it, just uncomment 'media' in "Software Sources" ..... And repeat : dpkg-dev is not required for ns2. ..... Generally for editing system files : sudo gedit <path-to-file>/"file" or cd <path-to-file> sudo gedit <file> sudo gedit /etc/apt/sources.list ... will do the trick. .....
Last edited by knudfl; 09-11-2009 at 09:11 AM.

09-11-2009, 09:23 AM

#15

neeraj.dwivedi
LQ Newbie Registered: Sep 2009 Posts: 27 Original Poster Rep:

and what about packages "libx11-dev" , "libxmu-dev" and "dpkg-dev" which are not available.. now give me the link or download location from which i could able to download these packages. or tell me any other way to get them. because from software sources or update manager i was unable to get them.??

11 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

Page 1 of 2 1 2 >

Tags linux, ubuntu

Posting Rules You You You You may may may may not not not not post new threads post replies post attachments edit your posts

BB code is On Smilies are On [IMG] code is Off HTML code is Off Trackbacks are Off Pingbacks are On Refbacks are Off Forum Rules

Similar Threads
Thread Problem in installing NS2 in fedora 5 NS2 2.33 allinone on Ubuntu Installing NS2 on red hat9 Problem Installing NS2 in Ubuntu 7.10 Encountering problem when installing NS2 on Debian Thread Starter arunram Liz Mwaniki Liz Mwaniki smetya MichaelYoung Forum Linux - Software Linux - Newbie Linux - Newbie Linux - Software Debian Replies 6 1 3 5 1 Last Post 03-14-2009 07:49 AM 01-26-2009 04:24 AM 01-26-2009 03:21 AM 04-27-2008 08:27 AM 05-12-2007 07:08 PM

All times are GMT -5. The time now is 04:13 AM. Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap Open Source Consulting | Domain Registration

12 of 13

9/9/2011 3:19 PM

[SOLVED] problem in installing ns2.33 in ubuntu 8.10

http://www.linuxquestions.org/questions/linux-newbie-8/problem-in-instal...

13 of 13

9/9/2011 3:19 PM