Sie sind auf Seite 1von 20

VisuAlg (parte 1)

Prof Valrio

Variveis
VAR
<identificador 1>, <identificador 2>, ..., <identificador n>: <tipo das variveis>
Onde <identificador i> o nome (identificador) de uma varivel e <tipo das variveis> determina que tipo de valor as variveis podero receber. A identificao ou nomeao de variveis segue algumas regras: a. nomes de variveis no podem ser iguais a palavras reservadas; b. nomes de variveis devem possuir como primeiro caractere uma letra ou sublinhado '_' (os outros caracteres podem ser letras, nmeros e sublinhado); c. nomes de variveis devem ter no mximo 127 caracteres; d. Nomes de variveis no podem conter espaos em branco; e. na sintaxe do Portugus Estruturado, no h diferena entre letras maisculas de minsculas (NOME o mesmo que noMe). Exemplos: Identificadores vlidos: NOME, TELEFONE, IDADE_FILHO, IdadeFilho, NOTA1, Est_Civil Identificadores invlidos: 3Endereco, Estado Civil, PARA, algoritmo, numero/complemento

Tipos de Dados
TIPO INTEIRO DESCRIO Representa valores inteiros. Exemplos: 10, 5, -5, -10 Representa valores reais (com ponto separador da parte decimal). Exemplos: 10, 15.5, -14.67 Representa texto (sequncia ou cadeia de caracteres) entre aspas duplas. Exemplo "Esta uma cadeia de caracteres", B, 1234

REAL ou NUMERICO

LITERAL ou CARACTERE

Comentrio

//
Exemplos
// Este mtodo calcula o fatorial de n...x <- y; // Inicializa a varivel x com o valor de y

Atribuio

<Exemplos: Peso <- 78.7 // Este comando atribui varivel Peso o valor 78.7
Nome <- "Joo da Silva" // Este comando atribui varivel Nome o valor "Joo da Silva". Achei <- FALSO // Este comando atribui varivel Achei o valor FALSO. S se pode atribuir s variveis valores do mesmo tipo da varivel.

Comando de entrada
Leia (<identificador>)
Exemplos:
leia (NumeroConta) leia (NumeroAgencia) leia (NomeCliente)

Comando de sada
Escreval (<expresso ou identificador ou constante>)
//Mostra o primeiro resultado na mesma linha depois em linhas diferentes.

Escreva (<expresso ou identificador ou constante>)


//Mostra o resultado na mesma linha, mas em colunas diferentes. Exemplos: Escreva ("O valor de X ", X) Escreva (" E o valor de Y ", Y) Escreval (" A soma de X e Y ", X+Y)

Operadores
a) Aritmticos

b) Relacionais

Operadores (cont.)
C) Operadores lgicos

Prioridades entre Operadores

Deciso Simples
se <condio> entao
<aes (uma ou mais) a serem realizadas se a condio for verdadeira>

fimse
Exemplo:
se Dinheiro >= 10 entao Ir_ao_Cinema <- VERDADEIRO Ver_TV <- FALSO Fimse

Deciso Composta
se <condio> entao
<aes (uma ou mais) a serem realizadas se a condio for verdadeira>

senao
<aes (uma ou mais) a serem realizadas se a condio for falsa>

fimse

Exemplo Deciso Composta


1. Algoritmo "Calcula Area do Circulo" 2. VAR 3. Area, Raio: Real 4. inicio 5. Escreval ("Entre com raio do crculo") 6. Leia (Raio) 7. Se Raio > 0 entao 8. Area <- PI*(Raio^2) 9. Escreva ("A rea do crculo de raio ", Raio, " ", Area) 10. senao 11. Escreva ("Raio no pode ser nulo ou negativo!") 12. fimse 13. fimalgoritmo

Caso
escolha < expresso-de-seleo > caso < exp 1 > , < exp 2 >, ... , < exp n > < lista-de-comandos-1 > caso < exp 1 > , < exp 2 >, ... , < exp n > < lista-de-comandos-2 > outrocaso < lista-de-comandos-3 > fimescolha

Exemplo Caso
1. Algoritmo "CLASSIFICAO DE ATLETAS 2. var 3. nome, categoria : caractere 4. idade : inteiro 5. inicio 6. Escreva("Nome do Atleta = ") 7. Leia (nome) 8. Escreva("Idade do Atleta = ") 9. Leia (idade) 10. Escolha idade 11. caso 5,6,7,8,9,10 12. categoria <- "Infantil" 13. caso 11,12,13,14,15 14. categoria <- "Juvenil" 15. caso 16,17,18,19,20 16. categoria <- "Junior" 17. caso 21,22,23,24,25 18. categoria <- "Profissional" 19. outrocaso 20. categoria <- "INVALIDO" 21. Fimescolha 22. Escreva ("Categoria = ",categoria) 23. fimalgoritmo

Comandos de Repetio - Repita


repita <lista de comandos> ate <expresso lgica ou relacional>
Exemplo: 1. algoritmo "DemonstraRepeticao" 2. VAR 3. i: INTEIRO 4. inicio 5. i<- 1 6. repita 7. escreva (i) 8. i<- i + 1 9. ate i > 10 10. fimalgoritmo 14. leia (b) 15. escreva ("Digite a terceira nota: ") 16. leia (c) 17. MH <- 3/(1/a + 1/b +1/c) 18. escreval ("A mdia harmnica do aluno: ", NOME, " ", MH) 19. i <- i + 1 20. ate i > 3 21. FimAlgoritmo

Ateno
Todo lao com varivel de controle deve conter:
a) inicializao da varivel de controle; b) incremento (aumento do valor da varivel de controle) ou decremento (diminuio do valor da varivel de controle) da varivel de controle; e c) teste de valor da varivel de controle.

Comandos de Repetio - Enquanto


enquanto <expresso lgica ou relacional> faca <lista de comandos> fimenquanto
Exemplo: Algoritmo que l diversos nmeros positivos e escreve, para cada um, sua raiz quadrada. 1. algoritmo comRepita 1. algoritmo comEnquanto 2. var 2. var 3. i: numerico 3. i: numerico 4. inicio 4. inicio 5. repita 5. leia (i) 6. leia (i) 6. enquanto i >=0 faca 7. se i >=0 entao 7. escreva (i^0.5) 8. escreva (i^0.5) 8. leia (i) 9. fimse 9. fimenquanto 10. ate i<0 10. fimalgoritmo 11. fimalgoritmo

Comandos de Repetio - Para


para <varivel de controle> de <valor inicial> ate <valor final> [passo <incremento>] faca <lista de comandos> fimpara
Exemplo: Um algoritmo que l escreve os nmeros mpares de 1 a 1000. 1. para i de 1 ate 1000 passo 2 faca // Incrementa i de 2 em 2 2. escreva i, mpar 3. fimpara