Sie sind auf Seite 1von 68

CIS 185 Advanced Routing Protocols

Routing IPv6
Rick Graziani
Cabrillo College
graziani@cabrillo.edu

Last Updated: Fall 2009
2
More IPv6
Simple and Efficient Header
A simpler and more efficient header means:
64-bit aligned fields and fewer fields
Hardware-based, efficient processing
Improved routing efficiency and performance
Faster forwarding rate with better scalability
4
IPv4 and IPv6 Header Comparison
Fragment
Offset
Flags
Total Length
Type of
Service
IHL
Padding Options
Destination Address
Source Address
Header Checksum Protocol Time to Live
Identification
Version
IPv4 Header
Next
Header
Hop Limit
Flow Label
Traffic
Class
Destination Address
Source Address
Payload Length
Version
IPv6 Header
Fields Name Kept from IPv4 to IPv6
Fields Not Kept in IPv6
Name and Position Changed in IPv6
New Field in IPv6
L
e
g
e
n
d

5
Resources
IPv6 Addressing At-A-Glance
http://cisco.com/application/pdf/en/us/guest/tech/tk872/c1550/cdccont_0900aecd80
26003d.pdf
IPv6 Extension Headers Review and Considerations
http://cisco.com/en/US/partner/tech/tk872/technologies_white_paper0900aecd8054
d37d.shtml
IPv6 Headers At-A-Glance
http://cisco.com/application/pdf/en/us/guest/tech/tk872/c1482/cdccont_0900aecd80
260042.pdf
IPv6 Mobility At-A-Glance
http://cisco.com/application/pdf/en/us/guest/tech/tk872/c1482/cdccont_0900aecd80
260046.pdf
Internet Protocol Version 6 Q&A
http://cisco.com/en/US/partner/products/ps6553/products_qanda_item0900aecd803
715bf.shtml
IPV6 Case Studies
http://cisco.com/en/US/partner/products/ps6553/prod_case_studies_list.html
IPv6 Allocations
http://www.ripe.net/rs/ipv6/stats/
Cisco IPv6 Solutions
http://cisco.com/en/US/partner/products/ps6553/products_white_paper09186a0080
2219bc.shtml
Implementing IPv6 with OSPF and
Other Routing Protocols
7
IPv6 Routing
Protocols
8
IPv6 Routing Protocols
IPv6 routing types:
Static
RIPng (RFC 2080)
EIGRP for IPv6
OSPFv3 (RFC 2740)
IS-IS for IPv6
MP-BGP4 (RFC 2545/2858)
ipv6 unicast-routing command is required to enable IPv6
before any routing protocol configured.
Otherswise, acts like an IPv6 host.
9
RIPng (the Next Generation)
For Enterprise Networks
10
RIPv2 vs RIPng
Advertises routes for
Layer 3/4 protocols
UDP Port
Use Distance Vector
Default Administrative distance
Supports VLSM
Automatic summarization
Uses Split Horizon
Uses Poison Reverse
30 second periodic full updates
Uses triggered updates
Uses Hop Count metric
Metric meaning infinity
Supports route tags
Multicast Update destination
Authentication
IPv4 IPv6
IPv4, UDP IPv6, UDP
520 521
yes yes
120 120
yes yes
yes N/A
yes yes
yes yes
yes yes
yes yes
yes yes
16 16
yes yes
224.0.0.9 FF02::9
RIP-specific uses IPv6 AH/ESP
11
R1(config)# ipv6 unicast-routing

R1(config)# interface FastEthernet0/0
R1(config-if)# ipv6 address 2012::1/64
R1(config-if)# ipv6 rip luigi enable

R1(config)# interface FastEthernet0/1
R1(config-if)# ipv6 address 2013::1/64
R1(config-if)# ipv6 rip luigi enable

R1(config)# interface Serial0/0/0
R1(config-if)# ipv6 address 2014::1/64
R1(config-if)# ipv6 rip luigi enable

R1(config)# interface Serial0/0/1
R1(config-if)# ipv6 address 2015::1/64
R1(config-if)# ipv6 rip luigi enable

R1(config)# ipv6 router luigi
Enable IPv6 routing
Configure an IPv6
addressing
and enable RIPng,
process luigi"
Create the RIPng
process named
luigi
12
R3# show ipv6 route
IPv6 Routing Table - Default - 19 entries
Codes: C - Connected, L - Local, S - Static, U - Per-
user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
<output omitted>

R 2005::/64 [120/3]
via FE80::11FF:FE11:1111, Serial0/0/0
via FE80::22FF:FE22:2222, Serial0/0/1
R 2012::/64 [120/2]
via FE80::11FF:FE11:1111, Serial0/0/0
via FE80::22FF:FE22:2222, Serial0/0/1
All next-hop IP addresses that begin with FE80
RIPng uses link local addresses as next-hop
addresses.
13
EIGRP for IPv6
For Winnebago Networks
14
EIGRP vs EIGRP for IPv6
Advertises routes for
Layer 3 protocol for EIGRP messages
Layer 3 header protocol type
UDP Port
Uses Successor, Feasible Successor
Uses Dual
Supports VLSM
Can perform automatic summarization
Uses triggered updates
Default metric bandwidth and delay
Multicast Update destination
Authentication
IPv4 IPv6
IPv4 IPv6
88 88
N/A N/A
yes yes
yes yes
yes yes
yes N/A
yes yes
yes yes
224.0.0.10 FF02::10
EIGRP-specific IPv6 AH/ESP
15
EIGRP RID decision steps based on IPv4 configuration:
1. Use the configured value (using the eigrp router-id a.b.c.d
EIGRP subcommand under the ipv6 router eigrp command)
2. Use the highest IPv4 address on an up/up loopback interface
3. Use the highest IPv4 address on an up/up non-loopback interface

IOS lets you stop and start the EIGRP process with the shutdown
and no shutdown router mode subcommands.
After initial configuration, the EIGRP for IPv6 process starts in
shutdown mode,
To start the EIGRP process it is required to issue the no
shutdown
EIGRP for IPv6
16
R1(config)# ipv6 unicast-routing

R1(config)# interface FastEthernet0/0
R1(config-if)# ipv6 address 2012::1/64
R1(config-if)# ipv6 eigrp 1

R1(config)# interface Serial0/0/0
R1(config-if)# ipv6 address 2014::1/64
R1(config-if)# ipv6 eigrp 1

R1(config)# ipv6 router eigrp 1
R1(config-router)# no shutdown
R1(config-router)# eigrp router-id 10.10.34.3
Enable IPv6
routing
Configure an
IPv6 addressing
and enable
EIGRP for IPv6
Create the
EIGRP for IPv6
process 1
17
R3# show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num

1 Link-local address: Se0/0/0 14 01:50:51 3 200 0 82
FE80::22FF:FE22:2222
0 Link-local address: Se0/0/0 13 01:50:52 14 200 0 90
FE80::11FF:FE11:1111

18
R3#show ipv6 eigrp topology
IPv6-EIGRP Topology Table for AS(9)/ID(10.10.34.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R -
Reply,r - reply Status, s - sia Status

P 2005::/64, 2 successors, FD is 2684416
via FE80::11FF:FE11:1111 (2684416/2172416),Serial0/0/0
via FE80::22FF:FE22:2222 (2684416/2172416),Serial0/0/0

19
OSPFv3
OSPFv3
20
OSPF vs OSPFv3
Advertises routes for
Layer 3 protocol
IP Protocol Type
Uses Link State logic
Supports VLSM
RID process, compared to OSPFv2
LSA flooding and aging compared to OSPFv2
Area structure compared to OSPFv2
Packet types
LSA flooding and aging compared to OSPFv2
RID
32-bit LSID
Cost metric, bandwidth
Supports route tags
DR/BDR election compared to OSPFv2
Periodic re-flooding every
Multicast all SPF routers
Multicast All Designated routers
Authentication
Neighbor checks compared to OSPFv2 (table 5-5)
multiple instances per interface
IPv4 IPv6
IPv4 IPv6
89 89
yes yes
yes yes
same same
same same
same same
same same
same same
yes yes
yes yes
yes yes
yes yes
yes yes
30 minutes 30 minutes
224.0.0.5 FF02::5
224.0.0.6 FF02::6
OSPF-specific uses IPv6 AH/ESP
same no "same subnet" check
no yes
21
OSPF Version 3 (OSPFv3) (RFC 2740)
Similar to OSPF for IPv4:
Same mechanisms, but a major rewrite of the internals of
the protocol

Updated features for IPv6:
Every IPv4-specific semantic is removed
Carry IPv6 addresses
Link-local addresses used as source
22
OSPFv3Similarities with OSPFv2
OSPFv3 is OSPF for IPv6 (RFC 2740):
Based on OSPFv2, with enhancements
Distributes IPv6 prefixes
Runs directly over IPv6
OSPFv3 & v2 can be run concurrently, because each address family
has a separate SPF (ships in the night).
OSPFv3 uses the same basic packet types as OSPFv2:
Hello
Database description blocks (DDB)
Link state request (LSR)
Link state update (LSU)
Link state acknowledgement (ACK)
Neighbor discovery and adjacency formation mechanism are identical.
LSA flooding and aging mechanisms are identical.
23
OSPFv3
Configuration
24
Lab 8-1 Configuring OSPF for IPv6
Configure a static IPv6 address on an interface
Change the default-link local address on an interface
Configure an EUI-64 IPv6 address on an interface
Enable IPv6 routing
Configure and verify single-area OSPFv3 operation
25
R1(config)# interface loopback0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# ipv6 address FEC0::1:1/112

R2(config)# interface loopback0
R2(config-if)# ip address 10.1.2.1 255.255.255.0
R2(config-if)# ipv6 address FEC0::2:1/112

R3(config)# interface loopback0
R3(config-if)# ip address 10.1.3.1 255.255.255.0
R3(config-if)# ipv6 address FEC0::3:1/112
Configure the loopback interface
on each router with both the IPv4
address (OSPF Router IDs) and
IPv6 address given in the diagram.
Configuring the Loopback Interfaces
26
R1(config)# interface serial0/0/0
R1(config-if)# ipv6 address FEC0::12:1/112
R1(config)# interface s0/0/1
R1(config-if)# ipv6 address FEC0::13:1/112

R2(config)# interface serial0/0/0
R2(config-if)# ipv6 address FEC0::12:2/112

R3(config)# interface serial0/0/0
R3(config-if)# ipv6 address FEC0::13:3/112
Configure the two serial links
with IPv6 addresses.

Configuring Static IPv6 Addresses
27
R1#ping FEC0::12:2
!!!!!
R1#ping FEC0::13:3
!!!!!

R2#ping FEC0::12:1

!!!!!

R3#ping FEC0::13:1
!!!!!

Verify with ping for local subnet
connectivity.
28
R1#show ipv6 interface serial 0/0/0
Serial0/0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::219:6FF:FE23:4380
No Virtual link-local address(es):
Global unicast address(es):
FEC0::12:1, subnet is FEC0::12:0/112
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF12:1
FF02::1:FF23:4380
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
Link-local address is based on the
eui-64 translation of the Fa 0/0
interface.
Changing the Link-Local Address on an Interface
29
R2#show ipv6 interface serial 0/0/0
Serial0/0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::218:B9FF:FE92:28D8
Global unicast address(es):
FEC0::12:2, subnet is FEC0::12:0/112
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF12:2
FF02::1:FF92:28D8
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
Link-local address is based on the
eui-64 translation of the Fa 0/0
interface.
30
R1(config)# interface serial0/0/0
R1(config-if)# ipv6 address FE80::1 link-local

R2(config)# interface serial0/0/0
R2(config-if)# ipv6 address FE80::2 link-local

R1#ping FE80::2
!!!!!

R2#ping FE80::1
!!!!!
You can change this on the link
between R1 and R2 by putting the link-
local address FE80::1 on R1 and
FE80::2 on R2.
To configure this, use the command
ipv6 address address link-local.
There is no subnet mask on link-local
addresses, because they are not
routed; hence the term link-local.

31
R1#show ipv6 interface serial 0/0/0
Serial0/0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::1
No Virtual link-local address(es):
Global unicast address(es):
FEC0::12:1, subnet is FEC0::12:0/112
<output omitted>

R2#show ipv6 interface serial 0/0/0
Serial0/0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::2
Global unicast address(es):
FEC0::12:2, subnet is FEC0::12:0/112
<output omitted>
Verify the link local addresses
32
R2(config)# interface fastethernet0/0
R2(config-if)# ipv6 address FEC0:23::/64 eui-64
R2(config-if)# no shutdown

R2#show ipv6 interface brief
FastEthernet0/0 [up/up]
FE80::218:B9FF:FE92:28D8
FEC0:23::218:B9FF:FE92:28D8
FastEthernet0/1 [administratively down/down]
Serial0/0/0 [up/up]
FE80::2
FEC0::12:2

EUI-64 IPv6 addresses are
addresses where the first 64 bits
are the network portion of the
address and specified, and the
second 64 bits are the host portion
of the address and automatically
generated by the device.
Configuring EUI-64 Addresses
33
R3(config)# interface fastethernet0/0
R3(config-if)# ipv6 address FEC0:23::/64 eui-64
R3(config-if)# no shutdown

R3#show ipv6 interface brief
FastEthernet0/0 [up/up]
FE80::218:B9FF:FECD:BEF0
FEC0:23::218:B9FF:FECD:BEF0
FastEthernet0/1 [administratively down/down]
Serial0/0/0 [up/up]
FE80::218:B9FF:FECD:BEF0
FEC0::13:3
EUI-64 IPv6 addresses are
addresses where the first 64 bits
are the network portion of the
address and specified, and the
second 64 bits are the host portion
of the address and automatically
generated by the device.
Configuring EUI-64 Addresses
34
R2#ping FEC0:23::218:B9FF:FECD:BEF0
!!!!!


R3#ping FEC0:23::218:B9FF:FE92:28D8
!!!!!


ping the other side of the link
35
R1(config)#interface loopback0
R1(config-if)#ipv6 ospf 1 area 0
R1(config)#interface serial0/0/0
R1(config-if)#ipv6 ospf 1 area 0
R1(config)#interface serial0/0/1
R1(config-if)#ipv6 ospf 1 area 0

R2(config)#interface loopback0
R2(config-if)#ipv6 ospf 1 area 0
R2(config)#interface serial0/0/0
R2(config-if)#ipv6 ospf 1 area 0
R2(config)#interface fastethernet0/0
R2(config-if)#ipv6 ospf 1 area 0

R3(config)#interface loopback0
R3(config-if)#ipv6 ospf 1 area 0
R3(config)#interface serial0/0/0
R3(config-if)#ipv6 ospf 1 area 0
R3(config)#interface fastethernet0/0
R3(config-if)#ipv6 ospf 1 area 0
Setting up OSPFv3
36
R1#show ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
10.1.3.1 1 FULL/ - 00:00:39 6 Serial0/0/1
10.1.2.1 1 FULL/ - 00:00:34 6 Serial0/0/0

R2#show ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
10.1.3.1 1 FULL/DR 00:00:39 4 FastEthernet0/0
10.1.1.1 1 FULL/ - 00:00:32 6 Serial0/0/0

R3#show ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
10.1.2.1 1 FULL/BDR 00:00:39 4 FastEthernet0/0
10.1.1.1 1 FULL/ - 00:00:39 7 Serial0/0/0
Verify that you have OSPFv3
neighbors
37
R1#show ipv6 route
L FE80::/10 [0/0]
via ::, Null0
C FEC0::1:0/112 [0/0]
via ::, Loopback0
L FEC0::1:1/128 [0/0]
via ::, Loopback0
O FEC0::2:1/128 [110/64]
via FE80::2, Serial0/0/0
O FEC0::3:1/128 [110/64]
via FE80::218:B9FF:FECD:BEF0, Serial0/0/1
C FEC0::12:0/112 [0/0]
via ::, Serial0/0/0
L FEC0::12:1/128 [0/0]
via ::, Serial0/0/0
C FEC0::13:0/112 [0/0]
via ::, Serial0/0/1
L FEC0::13:1/128 [0/0]
via ::, Serial0/0/1
O FEC0:23::/64 [110/65]
via FE80::2, Serial0/0/0
via FE80::218:B9FF:FECD:BEF0, Serial0/0/1
L FF00::/8 [0/0]
via ::, Null0
routing table
38
R1#show ipv6 ospf interface serial 0/0/1
Serial0/0/1 is up, line protocol is up
Link Local Address FE80::219:6FF:FE23:4380, Interface ID 7
Area 0, Process ID 1, Instance ID 0, Router ID 10.1.1.1
Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Index 1/3/3, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.1.3.1
Suppress hello for 0 neighbor(s)
Per-interface OSPF behavior
39
R2(config)#inter loop100
R2(config-if)#ipv6 add fec0:500::100:1/112
R2(config-if)#ipv6 ospf 1 area 500

R2(config)#inter loop200
R2(config-if)#ipv6 add fec0:500::200:1/112
R2(config-if)#ipv6 ospf 1 area 500

R2(config)#ipv6 router ospf 1
R2(config-rtr)#area 500 range fec0:500::/64
The commands available for
OSPFv3 are very close to the
commands available for OSPFv2.
On R2, add in two loopback
interfaces, with the addresses
FEC0:500::100:1 /112 and
FEC0:500::200:1 /112.
Add both of these interfaces to the
OSPF process in area 500.
Summarizing OSPFv3 Areas
FEC0:500::100:1 /112
FEC0:500::200:1 /112
Area 500
ABR
Use the area range
command to summarize the
address.
40
R1#show ipv6 route
OI FEC0:500::/64 [110/64]
via FE80::2, Serial0/0/0
Summarizing OSPFv3 Areas
FEC0:500::100:1 /112
FEC0:500::200:1 /112
Area 500
R1s routing table
ABR
41
Resources
IPv6 Routing At-A-Glance
http://cisco.com/application/pdf/en/us/guest/tech/tk872/c148
2/cdccont_0900aecd80260051.pdf
Deploying IPv6 Networks
By Ciprian P. Popoviciu, Eric Levy-Abegnoli, Patrick
Grossetete.
Published by Cisco Press
Copyright 2006
Using IPv6 with IPv4
IPv4-to-IPv6 Transition
Transition richness means:
No fixed day to convert; no need to convert all at once.
Different transition mechanisms are available:
Smooth integration of IPv4 and IPv6
Use of dual stack or 6-to-4 tunnels
44
Dual stack is an integration method where a node has
implementation and connectivity to both an IPv4 and IPv6
network.
If both IPv4 and IPv6 are configured on an interface, this interface
is dual-stacked.
Dual Stack
45
Tunneling
Tunneling is an integration method where an IPv6 packet is
encapsulated within another protocol, such as IPv4.
This is considered dual stacking.
Tunneling encapsulates the IPv6 packet in the IPv4 packet.
46
Isolated Dual-Stack Host
Encapsulation can also be done between a host and a router.
Configured tunnels require:
Dual-stack endpoints
IPv4 and IPv6 addresses configured at each end
Tunneling
48
Lab 8-2 Using Manual IPv6 Tunnels
Configure EIGRP for IPv4
Create a manual IPv6 tunnel
Configure OSPFv3
49
Manual IPv6 Tunnels
A manually configured tunnel is equivalent to a permanent link
between two IPv6 domains over an IPv4 backbone.
The primary use is for stable connections that require regular secure
communication between two edge routers or between an end
system and an edge router, or for connection to remote IPv6
networks.
50
R1(config)# interface loopback0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# ipv6 address FEC0::1:1/112
R1(config)# interface serial0/0/0
R1(config-if)# ip address 172.16.12.1 255.255.255.0

R2(config)# interface loopback0
R2(config-if)# ip address 10.1.2.1 255.255.255.0
R2(config)# interface serial0/0/0
R2(config-if)# ip address 172.16.12.2 255.255.255.0
R2(config)# interface serial0/0/1
R2(config-if)# ip address 172.16.23.2 255.255.255.0

R3(config)# interface loopback0
R3(config-if)# ip address 10.1.3.1 255.255.255.0
R3(config-if)# ipv6 address FEC0::3:1/112
R3(config)# interface serial0/0/1
R3(config-if)# ip address 172.16.23.3 255.255.255.0
Configure the loopback interfaces
(acting as a physical interface) on
Tunnel endpoints with IPv4 addresses
and IPv6 addresses (Both IPv4 and IPv6
hosts)
Configure the serial interfaces with the
IPv4 addresses
Configure R2 with IPv4
Configure Loopbacks and Physical Interfaces
Dual Stack
Dual Stack
51
R1(config)# router eigrp 1
R1(config-router)# no auto-summary
R1(config-router)# network 10.0.0.0
R1(config-router)# network 172.16.0.0

R2(config)# router eigrp 1
R2(config-router)# no auto-summary
R2(config-router)# network 10.0.0.0
R2(config-router)# network 172.16.0.0

R3(config)# router eigrp 1
R3(config-router)# no auto-summary
R3(config-router)# network 10.0.0.0
R3(config-router)# network 172.16.0.0
Configure EIGRP for AS 1 for the
major networks 172.16.0.0 and
10.0.0.0 on all three routers.
EIGRP will be used to route IPv4
networks.
Configure EIGRP
52
R1(config)# int tunnel0
R1(config-if)# tunnel mode ipv6ip
R1(config-if)# tunnel source s0/0/0
R1(config-if)# tunnel destination 172.16.23.3
R1(config-if)# ipv6 add FEC0::13:1/112

R3(config)# int tunnel0
R3(config-if)# tunnel mode ipv6ip
R3(config-if)# tunnel source s0/0/1
R3(config-if)# tunnel destination 172.16.12.1
R3(config-if)# ipv6 add FEC0::13:3/112
A tunnel is a logical interface that
acts as a logical connection
between two endpoints.
An IPv6 manual tunnel is a type of
tunnel that has hard-coded source
and destination addresses, with an
IPv6 address on the tunnel itself.
Configure a Manual IPv6 Tunnel
53
R1#ping FEC0::13:3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::13:3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms

R3#ping FEC0::13:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::13:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Verify that you can ping across the
tunnel to the other side
54
R1(config)# ipv6 unicast-routing
R1(config)# interface loopback0
R1(config-if)# ipv6 ospf 1 area 0
R1(config)# interface tunnel0
R1(config-if)# ipv6 ospf 1 area 0

R3(config)# ipv6 unicast-routing
R3(config)# interface loopback0
R3(config-if)# ipv6 ospf 1 area 0
R3(config)# interface tunnel0
R3(config-if)# ipv6 ospf 1 area 0
Configure OSPFv3 on those
routers to run over the tunnel and
advertise the loopback interfaces
into OSPFv3.
OSPFV3 will be used to route IPv6
networks.
(EIGRP is used for IPv4 networks.
Configure OSPFv3 over a Tunnel
55
R1#show ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
10.1.3.1 1 FULL/ - 00:00:37 18 Tunnel0

R1#ping FEC0::3:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/64/68 ms
Verify the configuration
56
Lab 8-3 Configuring 6to4 Tunnels
Configure EIGRP for IPv4
Create a 6to4 tunnel
Configure static IPv6 routes
57
Lab 8-3 Configuring 6to4 Tunnels
An automatic 6to4 tunnel allows isolated IPv6 domains to be
connected over an IPv4 network to remote IPv6 networks.
The key difference between automatic 6to4 tunnels and manually
configured tunnels is that the tunnel is not point-to-point; it is point-
to-multipoint.
58
R1(config)# interface loopback0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# ipv6 address FEC0::1:1/112
R1(config)# interface serial0/0/0
R1(config-if)# ip address 172.16.12.1 255.255.255.0

R2(config)# interface loopback0
R2(config-if)# ip address 10.1.2.1 255.255.255.0
R2(config)# interface serial0/0/0
R2(config-if)# ip address 172.16.12.2 255.255.255.0
R2(config)# interface serial0/0/1
R2(config-if)# ip address 172.16.23.2 255.255.255.0

R3(config)# interface loopback0
R3(config-if)# ip address 10.1.3.1 255.255.255.0
R3(config-if)# ipv6 address FEC0::3:1/112
R3(config)# interface serial0/0/1
R3(config-if)# ip address 172.16.23.3 255.255.255.0
Configure the loopback interfaces
(acting as a physical interface) on
Tunnel endpoints with IPv4 addresses
and IPv6 addresses (Both IPv4 and
IPv6 hosts)
Configure the serial interfaces with
the IPv4 addresses.
Configure Loopbacks and Physical Interfaces
59
R1(config)# router eigrp 1
R1(config-router)# no auto-summary
R1(config-router)# network 10.0.0.0
R1(config-router)# network 172.16.0.0

R2(config)# router eigrp 1
R2(config-router)# no auto-summary
R2(config-router)# network 10.0.0.0
R2(config-router)# network 172.16.0.0

R3(config)# router eigrp 1
R3(config-router)# no auto-summary
R3(config-router)# network 10.0.0.0
R3(config-router)# network 172.16.0.0
Configure EIGRP for AS 1 for the
major networks 172.16.0.0 and
10.0.0.0 on all three routers.
EIGRP is used to route the IPv4
networks.
Configure EIGRP
60
A 6to4 tunnel uses special IPv6
addresses in the 2002::/16 address
space.
The first 16 bits are the
hexadecimal number 2002, and
the next 32 bits are the original
source IPv4 address in
hexadecimal form.
A 6to4 tunnel does not require a
destination address because it is
not a point-to-point link.
Configure a Manual IPv6 Tunnel
61
R1(config)# interface tunnel 0
R1(config-if)# tunnel mode ipv6ip 6to4
R1(config-if)# ipv6 address 2002:AC10:0C01:1::1/64
R1(config-if)# tunnel source serial0/0/0


Set the source interface for
the tunnel with the tunnel
source command
Notice the two addresses are
not in the same /64 subnet.
Set the tunnel mode with the tunnel
mode ipv6ip 6to4 command.
Set the IPv6 address with the ipv6
address address/mask command.
Address for R1 is
2002:AC10:0C01:1::1/64:
AC10:0C01 = 172.16.12.1
AC = 172, 10 = 16, 0C = 12, 01 = 1
The 1 after this address is just a more
specific subnet, and the 1 at the end is
the host address.
2002:AC10:0C01:1::1/64
62
R3(config)# interface tunnel 0
R3(config-if)# tunnel mode ipv6ip 6to4
R3(config-if)# ipv6 address 2002:AC10:1703:1::3/64
R3(config-if)# tunnel source serial0/0/1

Set the source interface for
the tunnel with the tunnel
source command
Set the tunnel mode with the tunnel
mode ipv6ip 6to4 command.
Set the IPv6 address with the ipv6
address address/mask command.
Address for R3 is
2002:AC10:1703:1::3/64:
AC10:1703 = 172.16.23.3
AC = 172, 10 = 16, 17 = 23, 03 = 3
The 1 after this address is just a more
specific subnet, and the 3 at the end is
the host address.
2002:AC10:1703:1::3/64
63
R1(config)# ipv6 unicast-routing
R1(config)# ipv6 route 2002::/16 tunnel0

R3(config)# ipv6 unicast-routing
R3(config)# ipv6 route 2002::/16 tunnel0

R1#ping 2002:AC10:1703:1::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:1::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/67/68 ms

R3#ping 2002:AC10:C01:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/66/68 ms
Now that all the tunnel settings are
set, set up an IPv6 static route for
the whole 2002::/16 with the global
command ipv6 route
address/mask interface, with the
interface being the tunnel you just
created.
2002:AC10:1703:1::3/64
2002:AC10:0C01:1::1/64
64
R1(config)# ipv6 route FEC0::3:0/112 2002:AC10:1703:1::3

R3(config)# ipv6 route FEC0::1:0/112 2002:AC10:C01:1::1
Put a static route on R1 telling it
how to get to R3s loopback
address.
On R3, you will put a static
default route pointing to R1.
The next hop for both routers is
the IPv6 address of the other
end of the tunnel.
Configure Static IPv6 Routes
2002:AC10:0C01:1::1/64
2002:AC10:1703:1::3/64
65
R1#ping FEC0::3:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::3:1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
64/67/68 ms

R3#ping FEC0::1:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1:1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
64/66/68 ms
Verify
2002:AC10:0C01:1::1/64
2002:AC10:1703:1::3/64
66
R1#show ipv6 route
S 2002::/16 [1/0]
via ::, Tunnel0
C 2002:AC10:C01:1::/64 [0/0]
via ::, Tunnel0
L 2002:AC10:C01:1::1/128 [0/0]
via ::, Tunnel0
L FE80::/10 [0/0]
via ::, Null0
C FEC0::1:0/112 [0/0]
via ::, Loopback0
L FEC0::1:1/128 [0/0]
via ::, Loopback0
S FEC0::3:0/112 [1/0]
via 2002:AC10:1703:1::3
L FF00::/8 [0/0]
via ::, Null0
Verify routing table
2002:AC10:0C01:1::1/64
2002:AC10:1703:1::3/64
67
R3#show ipv6 route
S 2002::/16 [1/0]
via ::, Tunnel0
C 2002:AC10:1703:1::/64 [0/0]
via ::, Tunnel0
L 2002:AC10:1703:1::3/128 [0/0]
via ::, Tunnel0
L FE80::/10 [0/0]
via ::, Null0
S FEC0::1:0/112 [1/0]
via 2002:AC10:C01:1::1
C FEC0::3:0/112 [0/0]
via ::, Loopback0
L FEC0::3:1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
Verify routing table
2002:AC10:0C01:1::1/64
2002:AC10:1703:1::3/64
CIS 185 Advanced Routing Protocols
Routing IPv6
Rick Graziani
Cabrillo College
graziani@cabrillo.edu

Last Updated: Fall 2009

Das könnte Ihnen auch gefallen