Sie sind auf Seite 1von 24

MPLS TE Configuration

Course Objectives

MPLS TE tunnel configuration


TE FRR configuration

Course Outline

MPLS TE Basic Configuration


MPLS TE Protection Configuration

Network Topology
Lo1 1.1.1.1
10.0.1.0/24
.1

R1

1.
2.
3.

Lo1 3.3.3.3

Lo1 2.2.2.2

fei_1/1

10.0.2.0/24
.2

fei_1/1

.2

R2

fei_1/2

.1
fei_1/1

R3

To configure a TE tunnel of R1->R2->R3,


there are three steps:
Enable MPLS TE
Enable IGP TE on R1, R2 and R3.
Configure a tunnel on head end.

Enable MPLS TE

R1(config)#mpls traffic-eng tunnels


//Enable MPLS TE globally. The function is
disabled by default.
R1(config)#interface fei_1/1
R1(config-if)#mpls traffic-eng tunnels
//Enable MPLS TE on an interface
R1(config-if)#ip rsvp bandwidth 50000 20000
//Configure the maximum available bandwidth of
traffic engineering and LSP, use the following
command. The default value is 75% of physical
bandwidth.

Enable IGP TE

Here IGP uses OSPF. IS-IS can also be used.


R1(config)#router ospf 1
R1(config-router)#mpls traffic-eng area 0
//Configure the area that enables MPLS TE
R1(config-router)#mpls traffic-eng router-id
loopback1
//Configure Router ID used for TE
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#network 10.0.1.1 0.0.0.255 area
0

Enable IGP TE

If IGP uses IS-IS, the related configuration is shown below.


R1(config)#router isis
R1(config-router)#area 00
R1(config-router)#system-id 0010.0100.1001
R1(config-router)#metric-style wide
R1(config-router)#is-type level-1
R1(config-router)#mpls traffic-eng level-1
//Configure the levels that enable MPLS TE
R1(config-router)#mpls traffic-eng router-id loopback1
//Configure Router ID used for TE
R1(config)#interface fei_1/1
R1(config-if)#ip router isis

Tunnel Head End Configuration

R1(config)#interface tunnel1
R1(config-if)#tunnel mode mpls traffic-eng
//Set the tunnel mode as MPLS TE
R1(config-if)#ip unnumbered loopback1
//Configure the address of tunnel head end. The tunnel can
use valid IP address of other interface on the router to
save IP.
//To configure an IP address for the tunnel, use this
command:
R1(config-if)#ip address 1.1.21.1 255.255.255.255
R1(config-if)#tunnel destination ipv4 3.3.3.3
//Configure the address of tunnel tail end

Tunnel Head End Configuration

R1(config-if)#tunnel mpls traffic-eng path-option 1


explicit-path identifier 1
//Use explicit path for tunnel. Several path-options
can be configured. The system tries to establish
tunnels according to the order.
R1(config-if)# tunnel mpls traffic-eng bandwidth
10000
//Configure available bandwidth

Tunnel Head End Configuration

R1(config)#ip explicit-path identifier 1 next-address


10.0.1.2 strict
R1(config)#ip explicit-path identifier 1 next-address
10.0.2.1 strict
//To use strict explicit path, configure the link must be
passed by.
//to use loosen explicit path, the configuration is shown
below:
R1(config)#ip explicit-path identifier 1 next-address
2.2.2.2 loose
//It is necessary to configure the node that be passed by
in loosen explicit path.
R1(config)#ip explicit-path identifier 1 next-address
3.3.3.3 loose

View Tunnel Information


R1(config)#show mpls traffic-eng interface
//View states of interface related to MPLS TE
I/F
TE Hello interval(ms) misses BK-PATH I/f max(kbps)
flow max(kbps)
fei_1/1 YES NO 100
4
NO
50000
20000
R1(config)#show mpls traffic-eng tunnels summary
//View MPLS TE tunnel summary information
Signalling Summary:
LSP Tunnels Process:
running
RSVP Process:
running
Forwarding:
enabled
Head: 1 interfaces, 1 active signalling attempts, 1 established
Midpoints: 0, Tails: 0

View Tunnel Information


R1(config-if)#show mpls traffic-eng tunnels brief
//View MPLS TE tunnel brief information
Signalling Summary:
LSP Tunnels Process:

running

RSVP Process:

running

Forwarding:

enabled

TUNNEL NAME

DESTINATION

UP IF

DOWN IF STATE/PROT

tunnel_1

3.3.3.3

fei_1/1

up/up

View Tunnel Information


R1(config-if)#show mpls traffic-eng tunnels tunnel1
//View detailed information
Name: tunnel_1
(Tunnel1) Destination: 3.3.3.3
Status:
Admin: up Oper: up Path: valid Signalling: connected
Path option: 1, type explicit 1 (Basis for Setup)
Config Parameters:
Bandwidth: 10000 kbps (Global) Priority: 7 7 Affinity: 0x0/0x0
ClassType: 0 Bandwidth: 10000 kbps
Metric Type: IGP (default) Fast-reroute: disable
BFD:disable
disconnected
down
AutoRoute:disabled AutoRouteMetricType:IGP(default) AutoRouteMetric: 0
InLabel:
OutLabel:fei_1/1,16

View Tunnel Information

RSVP Signalling Info :


src 1.1.1.1 , Dst 3.3.3.3, Tun_Id 1, Tun_Instance 7
RSVP Path Info:
Explicit Route: 10.0.1.1 10.0.1.2 10.0.2.1 10.0.2.2 3.3.3.3
Record Route: NONE
Tspec:ave rate= 10000 kbits, burst= 2000 bytes, peak rate = 10000
kbits
RSVP Resv Info:
Record Route: NONE
Fspec:ave rate= 10000 kbits, burst= 2000 bytes, peak rate = 10000
kbits

View Tunnel Information

History:
Tunnel:
Time since created: 0 days, 0 hours, 7 minutes
Prior LSP: path option 1 [6]
Current LSP: Uptime:0 days, 0 hours, 0 minutes
Last tunnel down information :
Lsp_id[6] : local tunnel down by administrator[1]
Lsp_id[5] : local tunnel reactive[1]
Lsp_id[0] : none

Induct Traffic to MPLS TE Tunnel

(config)#ip route D.D.D.D X.X.X.X tunnel1


//Use static route forwarding
(config)# interface tunnel1
(config-if)# tunnel mpls traffic-eng autoroute
announce
//Use dynamic route forwarding. Tunnel1
participates in SPF calculation as a link

Course Outline

MPLS TE Basic Configuration


MPLS TE Protection Configuration

FRR Configuration
R1 Fei_1/1

Fei_1/1

10.1.1.1

10.1.1.2

Lo1:1.1.1.1

Fei_1/2
10.1.2.1

Fei_1/2 Lo1:3.3.3.3
10.1.3.1

Lo1:2.2.2.2
fei_1/1
10.1.2.2

R3

fei_1/2

R2

10.1.3.2

R1R3 is the active LSP. R1R2R3 is the standby LSP.


When the active tunnel is interrupted, traffics are changed
over to the standby tunnel automatically.

FRR Configuration
Interface configuration and OSPF/IS-IS related configuration are
omitted.
Establish active tunnel:
R1(config)#interface tunnel100
R1(config-if)#tunnel mode mpls traffic-eng
R1(config-if)#tunnel destination ipv4 3.3.3.3
R1(config-if)#tunnel mpls traffic-eng bandwidth 20000
R1(config-if)#tunnel mpls traffic-eng path-option 1 explicit-path
identifier 100
R1(config-if)#tunnel mpls traffic-eng fast-reroute
//Enable FRR protection in active tunnel
R1(config-if)#exit
R1(config)#ip explicit-path identifier 100 next-address 10.1.1.2 strict

FRR Configuration

Establish standby LSP tunnel:


R1(config)#interface tunnel200
R1(config-if)#tunnel mode mpls traffic-eng
R1(config-if)#tunnel destination ipv4 3.3.3.3
R1(config-if)#tunnel mpls traffic-eng bandwidth
20000
R1(config-if)#tunnel mpls traffic-eng path-option 1
explicit-path name pri
R1(config-if)#exit
R1(config)#ip explicit-path name pri next-address
10.1.2.2 strict

FRR Configuration

Enable FRR on interface


R1(config)#interface fei_1/1
R1(config-if)#mpls traffic-eng backup-path
tunnel200
R1(config-if)#ip rsvp bfd
//Enable BFD to monitor link state for RSVP
//RSVP Hello messages can also be used to
monitor link state.
R1(config-if)#ip rsvp hello
R1(config-if)#exit

View Standby Tunnel State


R1(config)#show mpls traffic-eng fast-reroute
Tunnel head end item information
Protected Tunnel
In-label Out intf/label FRR intf/label Status
Tunnel100
Tun hd fei_1/1:3
Tu200:16
ready
When the link between R1 and R3 is down:
R1(config-if)#show mpls traffic-eng fast-reroute
Tunnel head end item information
Protected Tunnel
In-label Out intf/label FRR intf/label Status
Tunnel100
Tun hd fei_1/1:3
Tu200:16
active

Review

Basic steps to configure MPLS TE

Main steps to configure TE FRR