Sie sind auf Seite 1von 38

PRESENTATION

ON
CCNA
TRAINED BY Malay Dubey
(Network Bulls Institute)

SUBMITTED BY Gagan
Sradana
ROLL NO. -13ce019

INTRODUCTION
CCNA stands for Cisco

Certified Network
Associate
It gives the information
about networking ,its types
and its application .
Networking is very
important as it provides
communication.
It is also very useful as it
helps in resource sharing.
Thus , overall it is a cost
saving technique.

TYPES OF NETWORKING
LAN It stands for local area network. Eg: network

within a campus .
MAN It stands for metropolitan area network. Eg:

network connecting various cities.


WAN It stands for wide area network. Eg :

internet on a whole world.

Networking Devices
LAN card
BRIDGE
HUB
SWITCH
ROUTER

Subnetting and Supernetting


About subnetting & Supernetting
In subnetting, a network is divided into several smaller subnetwork
with each subnetwork(or subnet) having its own subnetwork address.
In supernetting, an organization can combine several class C
addresses to create a larger range of addresses(supernetwork).

SUBNETTING
Class A, B, C in IP addressing are designed with two levels of hierarchy.
The organization has two-level hierarchical addressing, but it cannot
have more than one physical network./ The host cannot be organized
into groups, and all of the hosts are at the same level./ The
organization has one network with many hosts.
One solution to this problem is subnetting, the further division of a
network into smaller networks called subnetworks.

EXAMPLE OF SUBNETTING
( Example / Class A)
An organization with a class A address at least 1,000
subnetworks. Find the subnet mask and
configuration of each subnetwork.
(Solution)
1.
There is a need for at least 1,000 subnetworks.(we need at
least 1,002 subnetworks to allow for the all-1s and all-0s
subnetids)
2.
This means that the minimum number of bits to be
allocated for subnetting should be 10, (29 < 1,002 < 210).
3.
14 bits are left to define the hostids. Subnet mask
(11000000 = 192).

Range of addresses

Subnetworks in example

Classless Interdomain
Routing(CIDR)
Supernetting means assigning a set of class C addresses to an organization
that needs more than 254 host addresses.
However , when these class C addresses are entered into the routing table,
each occupies one entry in the routing table./ 256 entries in the routing
table.
The classless interdomain routing(CIDR) technique is devised to reduce
the number of routing table entries.
In this technique, instead of entering each single class C address with its
corresponding default mask(255.255.255.0), the router can use the
supernet mask and the lowest network address in the group.

CIDR

Hubs vs. switches


Hubs less expensive,

used in a very small


LAN where low
throughput is OK
Switches segments

collision domains,
interconnects network
segments, more
expensive, but
performance makes it
cost effective.

ROUTERS
It is a layer 3 or

network layer device.


In this there is no
broadcast.
It is WAN technology
device.
It is useful to connect
different networks.
Packet filtering & it
finds the best path
selection.

Router Configuration
Router always has two configurations:
Running configuration
In RAM, determines how the router is currently
operating
Is modified using the configure command
To see it: show running-config

Startup confguration
In NVRAM, determines how the router will operate
after next reload
Is modified using the copy command
To see it: show startup-config

Router Access Modes


User EXEC mode - limited examination of

router
Router>

Privileged EXEC mode - detailed examination

of router, debugging, testing, file


manipulation
Router#

ROM Monitor - useful for password recovery &

new IOS upload session


Setup Mode available when router has no
startup-config file

Logging Into The Router


Connect router to console port or telnet to

router
router>
router>enable
password
router#
router#?

USER MODE
PROMPT

PRIVILEDGED MODE
PROMPT

Configuring the router


Terminal (entering the commands directly)
router# configure terminal
router(config)#

Deleting Your Routers


Configuration
To delete your routers configuration

Router#erase startup-config

OR
Router#write erase

Router#reload
Router will startup again, but in setup mode, since
startup-config file does not exists

ROUTING
Routing is the

exchange of routes
between different
networks .
There are three types
of routing:
1. Default routing
2. Static routing
3. Dynamic routing

DYNAMIC ROUTING
A routing protocol is the communication used

between routers.
A routing protocol allows one router to share
information with other routers.
The information a router gets from another router,
using a routing protocol, is used to build & maintain a
routing table.
Examples of routing protocols:
1. RIP [ROUTING INFORMATION PROTOCOL]
2. EIGRP[ENHANCED INTERIOR GATEWAY ROUTING PROTOCOL]
3. OSPF[OPEN SHORTEST PATH FIRST]

Routing Information Protocol


(RIP)
RIP is a distance vector routing protocol
Hop count is used as the metric for path selection
If the hop count is greater than 15, the packet will be
discarded
By default, routing updates are broadcast every 30
seconds
RIP has evolved over the years from a Classful Routing
Protocol, RIP Version 1 (RIP v1), to a Classless Routing
Protocol, RIP Version 2 (RIP v2).
Configuring RIP
Router(config)#router rip

Enhanced Interior Gateway


Routing Protocol (EIGRP)
Really just an enhanced version of IGRP
A Cisco proprietary routing protocol
Called a hybrid protocol, but really just an advanced
distance vector protocol.
Fast convergence
Variable length subnet masks
Partial updates - only when the metric for a route
changes (bounded updates)
Multiple network layer support - IP, IPX, and AppleTalk
A router running EIGRP stores all its neighbors routing
tables so that it can quickly adapt or alternate routes.

Features of EIGRP

Classless Routing Protocol (VLSM, CIDR)


Faster convergence times and improved scalability
Multiprotocol support: TCP/IP, IPX/SPX, Appletalk
There is no IPX/SPX or Appletalk in CCNA or CCNP
Rapid Convergence and Better handling of routing loops
(DUAL)
Efficient Use of Bandwidth
Partial, bounded updates: Incremental updates only to the
routers that need them.
Minimal bandwidth consumption: Hello packets and by
default uses no more that 50% of links bandwidth EIGRP
packets.
PDM (Protocol Dependent Module)
Keeps EIGRP modular
Different PDMs can be added to EIGRP as new routed
protocols are enhanced or developed: IPv4, IPv6, IPX, and
AppleTalk

OSPF
Open Shortest Path

First
Dynamic IGP
(Interior Gateway
Protocol)

3
A

Use within your own

15

network

Link state algorithm

Shortest Path First

WhaT IS ACL?
Routers provide basic traffic
filtering capabilities, such as
blocking Internet traffic, with
access control lists (ACLs).
An ACL is a sequential list of
permit or deny statements
that apply to addresses or
upper-layer protocols.
This module will introduce
standard and extended ACLs
as a means to control network
traffic, and how ACLs are used

VLAN
VLAN stands for virtual
local area network.
Devices on different
VLAN must have a router to
communicate with each
other.
If devices are on the
same VLAN, then they can
communicate through a
switch.

INTER VLAN ROUTING


A VLAN is a broadcast domain and

unique ip subnet
Switches operate at layer2 (Data link
Layer)
VLANS cannot communicate without
L3 (Network Layer)
The L3 communication is called intervlan routing
Inter-vlan routing is a process of
forwarding network traffic from one
vlan to another using a router
The Subnets of your network facilitate
the routing process.
Router interfaces can be connected to
separate vlans.
Devices on vlans send traffic through
the router(L3) to other vlans.

How to configure EIGRP with RIP on same


network
In this article we will discuss how can two routing protocols exist in same network?
We have discussed basic of both EIGRP and RIP in our previous article. Now we will go
in more depth by including both RIP and EIGRP in same network.
Scenario
You are the administrator at abc.com. Company network is given below

R0
Port

IP address

Connected to

F0/0

80.0.0.1

R1 F0/1

F1/0

90.0.0.1

R2 F0/1

F1/1

100.0.0.1

R3 F0/1

R1
Port

IP address

Connected to

F0/0.10

10.0.0.1

S1 F0/24

F0/0.20

20.0.0.1

S1 F0/24

F0/1

80.0.0.2

R0 F0/0

S0/0/0

30.0.0.1

R2 S0/0

R2
Port

IP address

Connected to

F0/1

90.0.0.2

R0 F1/0

S0/0

30.0.0.2

R1 S0/0/0

F0/0

40.0.0.1

WR1 0/1

S0/1

50.0.0.1

R3 S0/0/1
R3

Port

IP address

Connected to

F0/1

100.0.0.2

R0 F1/1

S0/0/1

50.0.0.2

R2 S0/1

F0/0.60

60.0.0.1

S1 G0/1

F0/0.70

70.0.0.1

S1 G0/1

Configuration of R0
First we will configure R0. To configure double click on R0 select CLI and configure it as given below
To configure and enable RIP as backup routing on R0 follow these commands exactly.
R0>enable
R0#sh ip interface brief
Interface
IP-Address
OK? Method Status
Protocol
FastEthernet0/0
80.0.0.1
YES manual up
up
FastEthernet1/0
90.0.0.1
YES manual up
up
FastEthernet1/1
100.0.0.1
YES manual up
up
R0#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R0(config)#router rip
R0(config-router)#network 80.0.0.0
R0(config-router)#network 90.0.0.0
R0(config-router)#network 100.0.0.0
R0(config-router)#exit
R0(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
R0#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
R0#
We need not to configure EIGRP on it as its only going to be a backup route

Configuration of R1
Now configure R1. On R1 we need to configure both RIP and EIGRP. RIP for backup and EIGRP for main
route.
R1>enable
R1#show ip interface brief
Interface
IP-Address
OK? Method Status
Protocol
FastEthernet0/0
unassigned
YES manual up
up
FastEthernet0/0.10
10.0.0.1
YES manual up
up
FastEthernet0/0.20
20.0.0.1
YES manual up
up
FastEthernet0/1
80.0.0.2
YES manual up
up
Serial0/0/0
30.0.0.1
YES manual up
up
Serial0/0/1
unassigned
YES manual administratively down down
Vlan1
unassigned
YES manual administratively down down
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 30.0.0.0
R1(config-router)#network 80.0.0.0
R1(config-router)#exit
R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 30.0.0.0
R1(config-router)#exit
R1(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
R1#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
R1#

Configuration of R2
To configure and enable eigrp with rip routing on R2 follow these commands exactly.
Router>enable
R2#show ip interface brief
Interface
IP-Address
OK? Method Status
FastEthernet0/0
40.0.0.1
YES manual up
FastEthernet0/1
90.0.0.2
YES manual up
Serial0/0
30.0.0.2
YES manual up
Serial0/1
50.0.0.1
YES manual up
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#network 50.0.0.0
R2(config-router)#network 90.0.0.0
R2(config-router)#exit
R2(config)#router eigrp 1
R2(config-router)#network 30.0.0.0
R2(config-router)#
R2(config-router)#network 40.0.0.0
R2(config-router)#network 50.0.0.0
R2(config-router)#exit
R2(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
R2#

Protocol
up
up
up
up

Configuration of R3
To configure and enable eigrp with rip routing on R3 follow these commands exactly.
Router>enable
R3#show ip interface brief
Interface
IP-Address
OK? Method Status
Protocol
FastEthernet0/0
unassigned
YES manual up
up
FastEthernet0/0.60
60.0.0.1
YES manual up
up
FastEthernet0/0.70
70.0.0.1
YES manual up
up
FastEthernet0/1
100.0.0.2
YES manual up
up
Serial0/0/0
unassigned
YES manual administratively down down
Serial0/0/1
50.0.0.2
YES manual up
up
Vlan1
unassigned
YES manual administratively down down
R3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router rip
R3(config-router)#network 50.0.0.0
R3(config-router)#network 60.0.0.0
R3(config-router)#network 70.0.0.0
R3(config-router)#network 100.0.0.0
R3(config-router)#exit
R3(config)#router eigrp 1
R3(config-router)#network 50.0.0.0
R3(config-router)#network
R3(config-router)#network 60.0.0.0
R3(config-router)#network 70.0.0.0
R3(config-router)#exit
R3(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
R3#

Testing of EIGRP with RIP


Now we have configured both RIP and EIGRP in this network. To test this network double
click on PC-PT PC0 and select command prompt tracert 70.0.0.3