Sie sind auf Seite 1von 27

Cisco ITP in eServGlobal IN

IOS Interfaces

PS and Support Internal Training


Diegem
Imro Landveld
Implementation Practice

30 August 2006

2003 Cisco Systems 2006 eServGlobal Ltd

IOS Basics
Configuring IP Interfaces

IOS Interfaces | 2 | 2003 Cisco Systems

2006

IP Address and Physical Configuration


eSG-ITP(config)#
interface fastEthernet slot/port
eSG-ITP(config-if)# ip address ip-address subnet-mask
ip address 10.10.1.100 255.255.255.0
eSG-ITP(config-if)# speed [ 10 | 100 | auto ]
eSG-ITP(config-if)# duplex [ half | full | auto ]
speed 100
duplex full
no shutdown

Interface is (usually) fastEthernet slot / port

IP Address

(and /bay on 73xx,75xx,76xx)

Assigns an address and subnet mask

Starts IP processing on an interface

Sets format of network mask as seen in show commands

Physical Configuration

Define speed and Duplex settings

Auto sets up Auto-negotiation

Turn off shutdown, by default, it is disabled

IOS Interfaces | 3 | 2003 Cisco Systems

2006

IP Host Name and DNS Configuration


eSG-ITP(config) #
ip host name [ tcp-port-number ] address [ address
ip host paris 10.10.10.5 20.20.20.8
ip host stockholm 10.10.20.4
eSG-ITP(config) #
no ip domain-lookup
ip domain-name [ Domain Suffix ]
ip name-server [ IP Address or Host ]
ip domain name eservglobal.de
ip name-server 10.10.0.1

Host Names

Defines static host name to IP address mapping (/etc/hosts)

Hosts/interfaces selectable by name or IP address

Name Servers

Defines name servers for DNS lookups (or turns it off)

Defines a domain suffix for lookups

IOS Interfaces | 4 | 2003 Cisco Systems

2006

IP Routes

eSG-ITP(config) #
ip route <network> <mask> [ address/name ]
ip route
97.32.15.0
255.255.255.0
97.208.15.102
ip route
97.32.12.128 255.255.255.192 97.208.15.102
no ip route 97.32.12.128 255.255.255.192
eSG-ITP(config) #
ip route 0.0.0.0 0.0.0.0 [ default_router_address/name ]
ip route 0.0.0.0 0.0.0.0
97.253.109.1
no ip route 0.0.0.0 0.0.0.0

IP Route

Defined for a network with a network mask

Defines the router that is the next step to that network

Default Route

Name of the route for all the routes we dont know about

Uses the 0.0.0.0 for the network address with 0 mask bits set

IOS Interfaces | 5 | 2003 Cisco Systems

2006

Display IP Route Information


eSG-ITP(config)# show interface fastethernet0/0
eSG-ITP(config)# show ip routes

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 97.253.109.1 to network 0.0.0.0
S
C
C
S
C
C
C
S*

97.0.0.0/8 is variably subnetted, 7 subnets, 3 masks


97.32.12.64/26 [1/0] via 97.208.15.98
97.253.108.192/26 is directly connected, FastEthernet9/1/0
97.253.108.128/26 is directly connected, FastEthernet5/1/0
97.32.12.128/26 [1/0] via 97.208.15.106
97.208.15.104/30 is directly connected, FastEthernet5/0/0
97.208.15.96/30 is directly connected, FastEthernet9/0/0
97.253.109.0/27 is directly connected, FastEthernet5/0/1
0.0.0.0/0 [1/0] via 97.253.109.1

IOS Interfaces | 6 | 2003 Cisco Systems

2006

Display IP Interface Information

eSG-ITP(config)# show interface fastethernet0/0

FastEthernet0/0 is up, line protocol is up


Hardware is cyBus FastEthernet Interface, address is 0013.7fdc.9aa1
Description: SNMP Operations LAN
Internet address is 97.253.109.20/27
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:10, output 00:00:06, output hang never
Last clearing of "show interface" counters 6w2d
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec

IOS Interfaces | 7 | 2003 Cisco Systems

2006

IOS Basics
Configuring T1 and E1

IOS Interfaces | 8 | 2003 Cisco Systems

2006

What is an E-Carrier Level 1?

E1 is 2.048 Mbps split into 32 time slots

Full duplex (i.e. 2.048 Mbps upstream and downstream)

Each time slot sends and receives an 8-bit sample 8000 times per
second (8 x 8000 x 32 = 2,048,000 bps)
One timeslot (TS0) is reserved for framing purposes
Cyclic Redundancy Check can (optionally) be performed across all
bits transmitted in each frame to detect data loss
The G.703 standard specifies several options for the physical
transmission but HDB3 format is used almost exclusively

Each timeslot of of 64 Kbps is Digital Signal 0 (DS0)

Each timeslot can be a voice channel or signalling

One timeslot (TS16) is often reserved for signalling in ISUP

When all voice, known as IMT or PCM or ????

IOS Interfaces | 9 | 2003 Cisco Systems

2006

Channelized T1/E1 Overview

24 Subchannels
T1

30 Subchannels
E1

MUX

MUX

DS-0 framing for a single 64-kbps channel

DS-1 framing for a single 1.544-Mbps T1 or 2.108-Mbps E1

IOS Interfaces | 10 | 2003 Cisco Systems

2006

Channelized T1/E1 Configuration

eSG-ITP(config)# controller [ t1 | e1 ] slot / port


controller E1 0/0
eSG-ITP(config-controller)# channel-group number timeslots range
channel-group
0
timeslots
1

Configures T1 or E1 controller and enters controller


configuration mode
channel-group specifies the channel group (sub-channel)
associated with each time slot

Creates an interface serial slot/port:channel-group

e.g. Interface Serial0/0:0 in the above example

IOS Interfaces | 11 | 2003 Cisco Systems

2006

Channelized E1 Configuration
eSG-ITP(config-controller)# framing { crc4 | no-crc4 }
eSG-ITP(config-controller)# linecode { hdb3 | ami }
eSG-ITP(config-controller)# clock source { line | internal }
eSG-ITP(config)#
controller E1 0/0
eSG-ITP(config-controller)# framing NO-CRC4
eSG-ITP(config-controller)# clock source line
eSG-ITP(config-controller)# channel-group 0 timeslots 1
eSG-ITP(config-controller)# channel-group 1 timeslots 2
eSG-ITP(config-controller)# description 2-link E1 to SMS-C

Specifies the framing, line-code type and clock source required


for communication with the service provider
T1 is different.

framing is sf or esf

linecode is ami or b8zs

IOS Interfaces | 12 | 2003 Cisco Systems

2006

Channelized E1 Configuration Example

Channelized T1/E1 Port Adapter


E1 Line
(Port 0)
(Slot
0)
Cisco 2651

controller E1 0/0
framing no-crc4
linecode hdb3
clock source line
channel-group 0 timeslots 1
channel-group 1 timeslots 2
!
interface serial 0/0:0
description Link 1 to SMS-C
no ip address
Encapsulation mtp2
!
interface serial 0/0:1
description Link 2 to SMS-C
no ip address
Encapsulation mtp2

IOS Interfaces | 13 | 2003 Cisco Systems

2006

IOS Basics
Basic Connectivity Testing

IOS Interfaces | 14 | 2003 Cisco Systems

2006

Simple Ping
eSG-ITP> ping 10.10.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.1.10,
timeout is 2 seconds:
.!!!!
Success rate is 80 percent, round-trip min/avg/max = 1/1/1 ms
eSG-ITP>

Simple IP connectivity test


The extended ping command (ping without any parameters) is
very useful for load testing the IP interfaces in a deployment
We will have a test of this later

IOS Interfaces | 15 | 2003 Cisco Systems

2006

Extended Ping
eSG-ITP# ping
Protocol [ip]:
Target IP address: 192.168.101.162
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address:
Type of service [0]:
Set DF bit in IP header? [no]: yes
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.101.162, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
eSG-ITP#

Ping supported for several protocols, including SS7s MTP2

IOS Interfaces | 16 | 2003 Cisco Systems

2006

Extended Ping
eSG-ITP# ping
Protocol [ip]:
Target IP address: 10.10.1.53
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]: y
Sweep min size [36]:
Sweep max size [18024]:
Sweep interval [1]: 1000
Type escape sequence to abort.
Sending 90, [36..18024]-byte ICMP Echos to 10.10.1.53, timeout is 2 secs:
!!!<omitted>!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (90/90), round-trip min/avg/max = 1/22/168 ms

This is a fantastic utility to check that your networks are clean!

IOS Interfaces | 17 | 2003 Cisco Systems

2006

IP Trace
eSG-ITP# trace colon.eservglobal.be
Type escape sequence to abort.
Tracing the route to colon.eservglobal.be (203.118.128.138)
1
2
3
4
5
6
7

freddy.externalhp.com (16.132.12.16) 100 msec 8 msec 4 msec


eastern-gw.hopeful.com (16.144.16.22) 8 msec 8 msec 8 msec
external-a.chelmsford.mil (134.42.120.225) 8 msec 4 msec 4 msec
bb2.su.barrnet.net (131.119.254.6) 8 msec 8 msec 8 msec
su.arc.barrnet.net (131.119.3.8) 12 msec 12 msec 8 msec
moffett-fld-mb.in.mil (192.52.195.1) 216 msec 120 msec 132 msec
aba.nyc.mil (126.1.2.23) 412 msec
*
664 msec

Shows interface addresses used to reach the destination

IOS Interfaces | 18 | 2003 Cisco Systems

2006

Is the Link Operational?

Hardware
(Physical Layer)

Is the Carrier Detect signal present?

Cable
Connectors
Interface
Link

Data Link Layer

Keepalive Messages
Control Information
User Information

IOS Interfaces | 19 | 2003 Cisco Systems

Data
Are keepalive messages
being received?

2006

Interpreting show controller E1


eSG-ITP# show controller e1 0/0
E1 0/0 is up.
Applique type is Channelized E1 - balanced
Description: Slot zero controller for SMS E1s
No alarms detected.
alarm-trigger is not set
Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line
International Bit: 1, National Bits: 11111
Data in current interval (542 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Operational......................E1 is up - Shows that the E1 controller is operating.


Connection Problem..........E1 is down
Disabled..........................E1 is administratively down
Loopback conditions.Loopback conditions are locally or remotely looped.

IOS Interfaces | 20 | 2003 Cisco Systems

2006

Interpreting show interfaces serial

eSG-ITP# show interfaces serial 0/0:0


Serial0/0:0 is up, line protocol is up
Hardware is cxBus E1
Description: Link 1 to SMS-C
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SS7 MTP2, crc 16, loopback not set
Keepalive set (10 sec)
Last input 00:00:17, output 00:00:17, output hang never

Operational......................Serial is up, line protocol is up


Connection Problem..........Serial is up, line protocol is down
Interface Problem.............Serial is down, line protocol is down
Disabled..........................Serial is administratively down, line protocol is down

IOS Interfaces | 21 | 2003 Cisco Systems

2006

Interpreting show interfaces serial (cont)


continued
Last clearing of "show interface" counters 5d04h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 5000 bits/sec, 5 packets/sec
5 minute output rate 6000 bits/sec, 5 packets/sec
440216 packets input, 52829794 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
525678 packets output, 68281427 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions no alarm present
Timeslot(s) Used:1, subrate: 64Kb/s, transmit delay is 0 flags

Except for bits/sec, packets/sec and input/output packets and bytes, zero is good!

IOS Interfaces | 22 | 2003 Cisco Systems

2006

Interpreting show interfaces serial (cont)


continued
Last clearing of "show interface" counters 5d04h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 5000 bits/sec, 5 packets/sec
5 minute output rate 6000 bits/sec, 5 packets/sec
440216 packets input, 52829794 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
525678 packets output, 68281427 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions no alarm present
Timeslot(s) Used:1, subrate: 64Kb/s, transmit delay is 0 flags

clear counters will clear the counters on the interface

IOS Interfaces | 23 | 2003 Cisco Systems

2006

Troubleshooting LSL: Interface


I/F
Status

Line Protocol
status

Potential Cause
cabling (loopback, BERT)
interface shutdown

down

down

serial: DTE/DCE mismatch


T1/E1: framing/linecode mismatch
T1/E1: controller shutdown
Havent started linkset on bloody DK card
Link not configured as part of a linkset on ITP

up

down

Link/linkset administratively down


Link not activated on the remote end
Serial: clock rate not set
T1/E1: timeslot mismatch
SLT errors: NI, adjacent PC or SLC mismatch

up

toggling

dirty line, check interface counters or T1/E1 controller

IOS Interfaces | 24 | 2003 Cisco Systems

2006

Further Information
Further Information is available on:

E1 Error Events Troubleshooting

cisco.com/warp/public/116/E1_error.html

Cisco IOS Configuration Fundamentals Configuration Guide

cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffu
n_c/index.htm

Cisco IOS Configuration Fundamentals Command Reference

cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffu
n_r/index.htm

White paper The ABCs of Cisco IOS Software Release

cisco.com/application/pdf/en/us/guest/products/iosswrel/c1127/c
dccont_0900aecd80172ae9.pdf
IOS Interfaces | 25 | 2003 Cisco Systems

2006

Thats all Folks!

IOS Interfaces | 26 | 2003 Cisco Systems

2006

Backup Slides

IOS Interfaces | 27 | 2003 Cisco Systems

2006

Das könnte Ihnen auch gefallen