You are on page 1of 68

CCNA Exploration

IPv6 Addressing
IPv6 Address
Reasons
Representation
IPv4 Address Depletion
IP Address
Shortage Response

IPv6 increases the address size to 128 bits.

3.4x10^38 Undecillion IP Addreses

340,282,366,920,938,463,463,374,607,431,768,211,456
( To be Exact)

This provides roughly 50 octillion addresses per person.


Reasons of using IPv6

Population Growth

Mobile Users

Transportation

Consumer Electronics
IPv6 Address
Representation
1 2 3 4 5 6 7 8
2001:0DB8:FACE:0001:AB00:0000:0000:0068
16 Bits 16 Bits 16 Bits 16 Bits 16 Bits 16 Bits 16 Bits 16 Bits
128 Bits

IPv6 addresses are 128-bit addresses

Eight 16-bit segments or hextets

Hexadecimal (non-case sensitive)

Separated by colons (:)


Reducing the Size
of an IPv6 Address

First Rule: Leading zeros in any 16-bit segment do


not have to be written.

Second Rule: Successive fields of zeros can be


represented as two colons (::).

Third Rule: Two colons (::) can only be used once


in an address.
Reducing the Size
of an IPv6 Address
First Rule: Leading zeros in any 16-bit segment do
not have to be written.

Example:

1 2 3 4 5 6 7 8
2001:0DB8:FACE:0001:AB00:0000:0000:0068
2001: DB8:FACE: 1:AB00: 0: 0: 68

2001:DB8:FACE:1:AB00:0:0:68
Reducing the Size
of an IPv6 Address
Second Rule: Successive fields of zeros can be
represented as two colons (::).

Example:

1 2 3 4 5 6 7 8
2001:0DB8:FACE:0000:AB00:0000:0000:0068
2001: DB8:FACE: 0:AB00: 0: 0: 68
2001: DB8:FACE: 0:AB00: : 68

2001:DB8:FACE:0:AB00::68
Reducing the Size
of an IPv6 Address
Third Rule: Double colons (::) can only be used once
in an address.

Example:

1 2 3 4 5 6 7 8
2001:0DB8:0000:0000:AB00:0000:0000:0068
2001: DB8: 0: 0:AB00: 0: 0: 68
2001: DB8: :AB00: : 68

2001:DB8::AB00::68
2001:DB8:0:0:AB00::68
2001:DB8::AB00:0:0:68
Find the Mistake!
2001:0DB8:0000:0000:FFFF:0CA0:0000:0000

1) 2001:DB8::FFFF:CA0:0:0

2) 2001:db8:0:0:FFFF:0CA0:0:0

3) 2001:DB8::FFFF:CA0:0:0

4) 2001:db8::FFFF:ca0::

5) 2001:db8:0:0:FFFF:CA0::

6) 2001:db8::FFFF:CA:0:0
IPv6 Address
Types
Structure
Types of IPv6 Address

Type Description Topology


One to One

Unicast An address destined for a single interface.


A packet sent to a unicast address is delivered to
the interface identified by that address.

One to Many
An address for a set of interfaces (typically
belonging to different nodes).
Multicast A packet sent to a multicast address will be
delivered to all interfaces identified by that
address.

One to Nearest (Allocated from Unicast)


An address for a set of interfaces.
In most cases these interfaces belong to different
nodes.
Anycast created automatically when a single unicast
address is assigned to more than one interface.
A packet sent to an anycast address is delivered
to the closest interface as determined by the IGP.
IPv6 Unicast
Address Scopes

IPv6 Unicast
Address

Global Unicast Site or Unique-


Link-local Address
Address local Address
IPv4, IPv6 Comparison

IPv4 IPv6
Classes/Types A Global Unicast
B Unicast Address
C Link-local Address
D
E Site-local address
Multicast
Anycast
Addresses 2^32 Billion 3.4x10^38 Undecillion
Format Decimal Hexadecimal
Mask Decimal Prefix (/)
Notation
IPv6 Global Unicast
Address Scopes

Scopes Range Description


Global 2000 - 3FFF currently being assigned by IANA
for public use on IPv6 Internet.
Unicast
Link-local FE80 - FEBF used for automatic address
configuration, neighbor
discovery, router discovery.
Site/Unique- FC00 - FCFF Routed within a private network.
local
Similar to IPv4 private address.
(Deprecated)
IPv6 Global Unicast
Address CIDR Notation
IPv6 always use Prefixes.

In IPv4 prefix; the network portion of the address can


be identified by a dotted decimal netmask or bitcount.

255.255.255.0 or /24

IPv6 prefixes are always identified by bitcount (Prefix


Length/CIDR Format).

Prefix length notation example:

2001:0008:85A3:4000::/64
Structure of an IPv6
Global Unicast Address

32 Bits
IPv4 Network ID Host ID

128 Bits
IPv6 Network Prefix Interface ID
64 Bits 64 Bits
Structure of an IPv6
Global Unicast Address

IPv4 Network ID Host ID

192.168.10.123
2001:0008:85A3:4000:222:55FF:FE18:7DE8
IPv6 Network Prefix Interface ID

Network Prefix Interface ID


Global Routing Prefix Subnet ID

2001:0008:85A3:4000:222:55FF:FE18:7DE8
Structure of an IPv6
Global Unicast Address
128 Bits
Network Prefix Interface ID

64 Bits 64 Bits

Global Routing Prefix Subnet ID Interface ID


/23 /32 /48 /64

2001 0008 21B:D5FF:FE5B:A408


The Global Unicast Address
Registry consists of:
ISP Prefix
Site Prefix A 48-bit global routing prefix
A 16-bit subnet ID
Subnet Prefix
A 64-bit interface ID
Structure of an IPv6
Global Unicast Address
Hierarchical addressing based on prefixes.

Global Routing Prefix Subnet ID Interface ID

/23 /32 /48 /64

2001 0008 222:55FF:FE18:7DE8

Registry
(IANA/RIRs)
ISP Prefix
(PLDT/Globe)

Site Prefix
(C3P Corp.)

Subnet Prefix
(HRD/Acctg)
IPv6 Global Unicast
Address Hierarchy
Internet Assigned Numbers Authority
(IANA)

Regional Internet Registries


ARIN, RIPE NCC, APNIC,
LACNIC, AFRINIC

Local Internet Registries


(ISPs)

End Users
IPv6 Global Unicast
Address Hierarchy
IANA
Registries Regional Internet Registries
(APNIC)

Telco
ISPs (PLDT, Globe)

Sites C3P Corporation


(Organizations)

HRD, Acctg, Sales


Subnets MIS, Mktg, Finance

Nodes
(Workstations)
Interfaces
IPv6 Global Unicast
Address Example
Global Routing Prefix Subnet ID Interface ID

2001:0008:85A3:4000:222:55FF:FE18:7DE8
/23 /32 /48 /64 /64

Registries
(APNIC)
Interface ID
ISPs (Node/Workstation)
(Telco)
Site
(C3P Corp.)

Subnet
(ABC Company HR Dept.)
Configuring Global
Unicast Address

2 Ways to Configure an IPv6 Global


Unicast Address.

Static

Dynamic
Configuring Global
Unicast Address

Configuring a Static IPv6 Global Unicast Address.

R1(config)# config t
R1(config)# interface fa0/0
R1(config-if)# ipv6 address 2001:8:85A3:4000::1/64

Configuring an IPv6 Global Address with EUI-64 .

R1# config t
R1(config)# int fa0/0
R1(config-if)# ipv6 add 2001:8:85A3:4000::/64 eui-64
Verifying an
IPv6 Address

Router#sho ipv6 int brief

FastEthernet0/0 [up/up]

FE80::222:55FF:FE18:7DE8 Link-local Address

2001:8:85A3:4000::1 Assigned Statically

2001:8:85A3:4000:222:55FF:FE18:7DE8

Assigned using EUI-64


Verifying an
IPv6 Address

Router#sho ipv6 int fa0/0


FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::222:55FF:FE18:7DE8
No Virtual link-local address(es):
Global unicast address(es):
2001:8:85A3:4000 ::1, subnet is 2001:8:85A3:4000::/64
2001:8:85A3:4000:222:55FF:FE18:7DE8,
subnet is 2001:8:85A3:4000::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:1
FF02::1:FFC4:1201
Special (Reserved)
IPv6 Addresses
IPv6
Description
Address
All networks and used when specifying a default
::/0 static route.
It is equivalent to the IPv4 quad-zero (0.0.0.0)
Unspecified address and is initially assigned to a
::/128
host when it first resolves its local link address
Loopback address of local host
::1/128
Equivalent to 127.0.0.1 in IPv4
Link-local unicast address
FE80::/10 Similar to the Windows autoconfiguration IP
address of 169.254.x.x

FF00::/8 Multicast addresses


IPv6
Link-local Address
IPv6 Link-local Address

Can be assigned dynamically and statically


Are NOT routable off the link.
Used by adjacent routers to exchange routing
updates
Used to communicate with other devices on the same
link.

Starts with FE80::/10 plus a 64-Bit Interface


Identifier.
128 bits
/10 /64
FE80 Interface ID
1111 1110 1000 0000 0000 ..0000 0000
IPv6 Link-local Address

Example:

R1# show ipv6 interface loopback 100


Loopback100 is up, line protocol is up
IPv6 is enabled, link-local address is
FE80::222:55FF:FE18:7DE8
No Virtual link-local address(es):
Global unicast address(es):
2001:8:85A3:4000:222:55FF:FE18:7DE8,
subnet is 2001:8:85A3:4000::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF18:7DE8
Assigning Dynamic
Link-local Address

Router(config)# interface fastethernet 0/1


Router(config-if)# ipv6 enable
Router(config-if)# end
Router# show ipv6 interface brief
FastEthernet0/1 [up/up]
FE80::20C:30FF:FE10:92E1

Link-local unicast
address only
Assigning Static
Link-local Address

R1(config)# interface fa0/0


R1(config-if)# ipv6 address FE80::1 ?
link-local use link-local address

R1(config-if)# ipv6 address FE80::1 link-local


R1(config-if)# end

The prefix mask is not required because they are not


routed.
Verifying Static
Link-local Address

Router(config-if)#do sho ipv6 int s0/0/0


Serial0/0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::1
No Virtual link-local address(es):
Global unicast address(es):
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:1
EUI-64
(Extended Unique Identifier-64)
EUI-64
(Extended Unique Interface-64)

Global Routing Prefix Subnet ID Interface ID


/23 /32 /48 /64
2001 0008 SID 290:27FF:FE17:FC0F

Registry
EUI-64
ISP Prefix
Site Prefix
Subnet Prefix
EUI-64
(Extended Unique Interface-64)

Interface identifiers in IPv6 unicast addresses are


used to identify interfaces on a link.

required to be unique within a subnet prefix, and


automatically assigned.

It is based on the 48-bit MAC address of the


interface with an additional 16-bit (FFFE) inserted
in the middle of the MAC address.

A 48-bit MAC address:

00-90-27-17-FC-0F
MAC Address
to EUI-64 Address
MAC Address
00 90 27 17 FC 0F

00 90 27 FF FE 17 FC 0F

0000 0000 90 27 FF FE 17 FC 0F

0000 0010 90 27 FF FE 17 FC 0F

EUI-64 Address

0290:27FF:FE17:FC0F
Configuring & Verifying
EUI-64 Address
Configuring EUI-64:

R1(config)# interface fastethernet 0/0


R1(config-if)# ipv6 address 2001:db8:aaaa:1::/64 eui-64

Verifying EUI-64:

R1# show ipv6 interface fastethernet 0/0


FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::290:27FF:FE17:FC0F
Global unicast address(es):
2001:db8:aaaa:1:290:27FF:FE17:FC0F
subnet is 2001:db8:aaaa:1::/64
<output omitted for brevity>
Verifying IPv6

Command Purpose
show ipv6 interface Displays the status of intesrfaces configured for
IPv6.

show ipv6 interface Displays a summarized status of interfaces


brief configured for IPv6.

show ipv6 neighbors Displays IPv6 neighbor discovery cache


information.

show ipv6 protocols Displays the parameters and current state of the
active IPv6 routing protocol processes.

show ipv6 rip Displays information about current IPv6 Routing


Information Protocol (RIP) processes.

show ipv6 route Displays the current IPv6 routing table.


Configuring Routers with IPv6
Static Route
RIPng
EIGRP
OSPF
Static Route with IPv6
Router1
Router0 2001:2:2:2::/64 2001:3:3:3::/64 Router3

s0/0/1
s0/0/0
s0/0/1 s0/0/0

PC1 fa0/0 fa0/0


PC2
2001:1:1:1::/64 2001:4:4:4::/64

ROUTER 0 ROUTER 1 ROUTER 3


config t config t config t
ipv6 unicast-routing ipv6 unicast-routing ipv6 unicast-routing
ipv6 route ::/0 2001:2:2:2::1 ipv6 route 2001:1:1:1::/64 s0/0/0 ipv6 route ::/0 2001:3:3:3::1
int fa0/0 ipv6 route 2001:4:4:4::/64 s0/0/1 int fa0/0
ipv6 add 2001:1:1:1::1/64 int s0/0/0 ipv6 add 2001:4:4:4::1/64
ipv6 add 2001:1:1:1::/64 eui-64 ipv6 add 2001:2:2:2::1/64 ipv6 add 2001:4:4:4::/64 eui-64
no shut ipv6 add 2001:2:2:2::/64 eui-64 no shut
int s0/0/1 clock rate 64000 int s0/0/0
ipv6 add 2001:2:2:2::2/64 no shut ipv6 add 2001:3:3:3::2/64
ipv6 add 2001:2:2:2::/64 eui-64 int s0/0/1 ipv6 add 2001:3:3:3::/64 eui-64
no shut ipv6 add 2001:3:3:3::1/64 no shut
do wr ipv6 add 2001:3:3:3::/64 eui-64 do wr
clock rate 64000
no shut
do wr
RIPng with IPv6
2001:2:2:2::/64 Router1 2001:3:3:3::/64
Router1 Router3
s0/0/1
s0/0/1
s0/0/0
s0/0/0
fa0/0 fa0/0

PC1
2001:1:1:1::/64 2001:4:4:4::/64 PC2

ROUTER 0 ROUTER 1 ROUTER 3


config t config t config t
hostname Router1 hostname Router2 hostname Router3
ipv6 unicast-routing ipv6 unicast-routing ipv6 unicast-routing
ipv6 router rip RIPv6 ipv6 router rip IPv6 ipv6 router rip IPv6
int fa0/0 int s0/0/0 int fa0/0
ipv6 rip RIPv6 enable ipv6 rip RIPv6 enable ipv6 rip RIPv6 enable
ipv6 add 2001:1:1:1::1/64 ipv6 add 2001:2:2:2::1/64 ipv6 add 2001:4:4:4::1/64
ipv6 add 2001:1:1:1::/64 eui-64 ipv6 add 2001:2:2:2::/64 eui-64 ipv6 add 2001:4:4:4::/64 eui-64
no shut clock rate 64000 no shut
int s0/0/1 no shut int s0/0/0
ipv6 rip RIPv6 enable int s0/0/1 ipv6 rip RIPv6 enable
ipv6 add 2001:2:2:2::2/64 ipv6 rip RIPv6 enable ipv6 add 2001:3:3:3::2/64
ipv6 add 2001:2:2:2::/64 eui-64 ipv6 add 2001:3:3:3::1/64 ipv6 add 2001:3:3:3::/64 eui-64
no shut ipv6 add 2001:3:3:3::/64 eui-64 no shut
do wr clock rate 64000 do wr
no shut
do wr
EIGRP with IPv6
2001:2:2:2::/64 Router1 2001:3:3:3::/64
Router1 Router3
s0/0/1
s0/0/1
s0/0/0
s0/0/0
fa0/0 fa0/0

PC1
2001:1:1:1::/64 2001:4:4:4::/64 PC2

ROUTER 0 ROUTER 1 ROUTER 3


config t config t config t
hostname Router1 hostname Router2 hostname Router3
ipv6 unicast-routing ipv6 unicast-routing ipv6 unicast-routing
ipv6 router eigrp 1 ipv6 router eigrp 1 ipv6 router eigrp 1
router-id 1.1.1.1 router-id 3.3.3.3 router-id 2.2.2.2
no shut no shut no shut
int fa0/0 int s0/0/0 int fa0/0
ipv6 enable ipv6 enable ipv6 enable
ipv6 eigrp 1 ipv6 eigrp 1 ipv6 eigrp 1
ipv6 add 2001:1:1:1::1/64 ipv6 add 2001:2:2:2::1/64 ipv6 add 2001:4:4:4::1/64
ipv6 add 2001:1:1:1::/64 eui-64 ipv6 add 2001:2:2:2::/64 eui-64 ipv6 add 2001:4:4:4::/64 eui-64
no shut clock rate 64000 no shut
int s0/0/1 no shut int s0/0/0
ipv6 enable int s0/0/1 ipv6 enable
ipv6 eigrp 1 ipv6 enable ipv6 eigrp 1
ipv6 add 2001:2:2:2::2/64 ipv6 eigrp 1 ipv6 add 2001:3:3:3::2/64
ipv6 add 2001:2:2:2::/64 eui-64 ipv6 add 2001:3:3:3::1/64 ipv6 add 2001:3:3:3::/64 eui-64
no shut ipv6 add 2001:3:3:3::/64 eui-64 no shut
do wr clock rate 64000 do wr
no shut
do wr
OSPF with IPv6
2001:2:2:2::/64 Router1 2001:3:3:3::/64
Router1 Router3
s0/0/1
s0/0/1
s0/0/0
s0/0/0
fa0/0 fa0/0

PC1
2001:1:1:1::/64 2001:4:4:4::/64 PC2

ROUTER 0 ROUTER 1 ROUTER 3


config t config t config t
hostname Router1 hostname Router2 hostname Router3
ipv6 unicast-routing ipv6 unicast-routing ipv6 unicast-routing
ipv6 router ospf 1 ipv6 router ospf 1 ipv6 router ospf 1
router-id 1.1.1.1 router-id 3.3.3.3 router-id 2.2.2.2
no shut no shut no shut
int fa0/0 int s0/0/0 int fa0/0
ipv6 enable ipv6 enable ipv6 enable
ipv6 ospf 1 area 1 ipv6 ospf 1 area 0 ipv6 ospf 1 area 2
ipv6 add 2001:1:1:1::1/64 ipv6 add 2001:2:2:2::1/64 ipv6 add 2001:4:4:4::1/64
ipv6 add 2001:1:1:1::/64 eui-64 ipv6 add 2001:2:2:2::/64 eui-64 ipv6 add 2001:4:4:4::/64 eui-64
no shut clock rate 64000 no shut
int s0/0/1 no shut int s0/0/0
ipv6 enable int s0/0/1 ipv6 enable
ipv6 ospf 1 area 0 ipv6 enable ipv6 ospf 1 area 0
ipv6 add 2001:2:2:2::2/64 ipv6 ospf 1 area 0 ipv6 add 2001:3:3:3::2/64
ipv6 add 2001:2:2:2::/64 eui-64 ipv6 add 2001:3:3:3::1/64 ipv6 add 2001:3:3:3::/64 eui-64
no shut ipv6 add 2001:3:3:3::/64 eui-64 no shut
do wr clock rate 64000 do wr
no shut
do wr
IPv6 Multicast
Addresses
IPv6 Multicast Addresses
Multicasting is at the core of many IPv6 functions
and is a replacement for the broadcast address.
They are defined by the prefix FF00::/8.

128 bits
/8 /16

F F 0 0 Group ID
1111 1111 00xx xxxx

FF00::/8
IPv6 Multicast Addresses

The second octet of the address contains the prefix


and transient (lifetime) flags, and the scope of the
multicast address.

128 bits
/8 /16

F F 0 0
Group ID
1111 1111 00xx xxxx

Flags:
P = Prefix for unicast-based assignments
T = 0 if permanent, 1 if temporary
Flags Scope
Scope:
0 0 P T xxxx 1 (0001) = Node
2 (0010) = Link
8 bits 5 (0101) = Site
8 (1000) = Organization
E (1110) = Global
IPv6 Multicast Address

The multicast addresses FF00:: to FF0F:: are


permanent and reserved.

128 bits
/8 /16

F F 0 0
Group ID
1111 1111 00xx xxxx

Flags:
P = Prefix for unicast-based assignments
Flags Scope T = 0 if permanent, 1 if temporary

0 0 P T xxxx Scope:
1 (0001) = Node
8 bits 2 (0010) = Link
5 (0101) = Site
8 (1000) = Organization
E (1110) = Global
Reserved IPv6
Multicast Addresses

Reserved
Description
Multicast Address

FF02::1 All nodes on a link (link-local scope).

FF02::2 All routers on a link.

All routing information protocol (RIP) routers on


FF02::9
a link.
All solicited-node multicast addresses used for
host autoconfiguration and neighbor discovery
(similar to ARP in IPv4).
FF02::1:FFxx:xxxx
The xx:xxxx is the far right 24 bits of the
corresponding unicast or anycast address of the
node.

FF05::101 All Network Time Protocol (NTP) servers.


IPv6 Multicast
Address Example

Router#sho ipv6 interface s0/0/1

Serial0/0/1 is up, line protocol is up


IPv6 is enabled, link-local address is FE80::2D0:BCFF:FE3C:4402
No Virtual link-local address(es):
Global unicast address(es):
2001:2:2:2::2, subnet is 2001:2:2:2::/64
2001:2:2:2:2D0:BCFF:FE3C:4402, subnet is 2001:2:2:2::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:2
FF02::1:FF3C:4402
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
Hosts use stateless autoconfig for addresses.
Solicited-Node
Multicast Addresses

The solicited-node multicast address (FF02::1:FF)


is used for:
Neighbor discovery (ND) process
Stateless address autoconfiguration

The Neighbor discovery (ND) process is used to:


Determine the local-link address of the neighbor
Determine the routers on the link and default route
Keep track of neighbor reachability
Send network information from routers to hosts
Neighbor Discovery
ICMPv6 Packet Types
Neighbor Discovery uses four ICMPv6 packet types
ICMPv6
Type Description
Message
Sent by a host to determine the link-layer address of a
neighbor.
Neighbor
135 Used to verify that a neighbor is still reachable.
Solicitation (NS)
An NS is also used for Duplicate Address Detection
(DAD).
Neighbor A response to a NS message.
Advertisement 136 A node may also send unsolicited NA to announce a
(NA) link-layer address change.
RAs contain prefixes that are used for on-link
Router determination or address configuration, a suggested
Advertisement 134 hop limit value and MTU value.
(RA) RAs are sent either periodically, or in response to a RS
message.
When a host is booting it sends out an RS requesting
Router
133 routers to immediately generate an RA rather than wait
Solicitation (RS)
for their next scheduled time.
Neighbor Solicitation
Example

A B

ICMP type: 135 (NS)


Source: A
Destination: Solicited-node multicast of B
(FF02::1:FFxx.xxxx)
Data: Link-layer address of A
Query: What is your link-layer address?

ICMPv6 Neighbor Solicitation (NS) is similar to IPv4 ARP.


For Host A to send a packet to Host B it needs the MAC address
of Host B.
Neighbor Advertisement
Example

A B

ICMP type: 136 (NA)


Source: B
Destination: A
Data: Link-layer address of B

Each destination node that receives the NS responds with an ICMPv6 message
type 136, NA, including Host B.

A B

A and B can now exchange packets on this link.


IPv6 Autoconfiguration
Stateless Address Autoconfiguration
(SLAAC)

Every IPv6 system is able to build its own unicast


global address.
Enables new devices to easily connect to the
Internet.
No configuration or DHCP server is required.

IPv6 Router - sends network info on local link.


IPv6 prefix
Default IPv6 route

IPv6 Hosts - listen on local link and configure themselves.


IP Address (EUI-64 format)
Default route
Stateless Address
Autoconfiguration

An IPv6 address must be configured on the


router gateway interface.

IPV6 IPV6
Router Host
Local Link MAC Address
00:14:BF:7A:3C:E5

RA

Router sends network info Autoconfiguration Address


(IPV6 Prefix and Default IPv6 (IPv6 Prefix + Link-Layer EUI Address)
Route)
Ethernet EUI-64
IPv6 Addresses

The first 64 bits are the network portion of the address


and are statically specified or learned via SLAAC.

The interface ID (second 64-bits) is the host portion of


the address and is automatically generated by the
router or host device.

The interface ID on an Ethernet link is based on the 48-


bit MAC address of the interface with an additional 16-
bit 0xFFFE inserted in the middle of the MAC address.
EUI-64
IPv6 Interface Identifier

48-bit MAC Address

64-bit IPv6 EUI-64 Interface ID


Stateless Autoconfiguration
Process

R1

ICMP type: 133 (RS)


Source: ::
Destination: All routers multicast address
(FF02::2)
Query: Please send RA

R1

ICMP type: 134 (RA)


Source: R1 link-local address
Destination: All nodes multicast address
(FF02::1)
Data: Options, prefixes, lifetime,
Stateless Autoconfiguration
Process

A B

ICMP type: 135 (NS)


Source: ::
Destination: Solicited-node address of A
Data: Link-layer address of A
Query: What is your link-layer address?

Host A creates an IPv6 address using the RA supplied


by the router.

Host A verifies that its new IPv6 address is unique


using DAD process.
Thank You!
The first three octets (in transmission order) identify the organization that issued the
identifier and are known as the Organizationally Unique Identifier (OUI).[3] The following
three (MAC-48 and EUI-48) or five (EUI-64) octets are assigned by that organization in nearly
any manner they please, subject to the constraint of uniqueness. The IEEE expects the MAC-
48 space to be exhausted no sooner than the year 2100;[3] EUI-64s are not expected to run
out in the foreseeable future. A locally administered address is assigned to a device by a
network administrator, overriding the burned-in address. Locally administered addresses do
not contain OUIs.
Universally administered and locally administered addresses are distinguished by setting the
second-least-significant bit of the most significant byte of the address. This bit is also referred
to as the U/L bit, short for Universal/Local, which identifies how the address is administered.
If the bit is 0, the address is universally administered. If it is 1, the address is locally
administered. In the example address 06-00-00-00-00-00 the most significant byte is 06
(hex), the binary form of which is 00000110, where the second-least-significant bit is 1.
Therefore, it is a locally administered address.[4] Consequently, this bit is 0 in all OUIs.
If the least significant bit of the most significant octet of an address is set to 0 (zero), the
frame is meant to reach only one receiving NIC.[5] This type of transmission is called unicast. A
unicast frame is transmitted to all nodes within the collision domain, which typically ends at
the nearest network switch or router. Only the node with the matching hardware MAC
address will accept the frame; network frames with non-matching MAC-addresses are
ignored, unless the device is in promiscuous mode.
If the least significant bit of the most significant address octet is set to 1, the frame will still
be sent only once; however, NICs will choose to accept it based on different criteria than a
matching MAC address: for example, based on a configurable list of accepted multicast MAC
addresses. This is called multicast addressi
IPv6 Global Unicast
Address Example

R1# show ipv6 interface loopback 100


Loopback100 is up, line protocol is up
IPv6 is enabled, link-local address is
FE80::222:55FF:FE18:7DE8
No Virtual link-local address(es):
Global unicast address(es):
2001:8:85A3:4000:222:55FF:FE18:7DE8
subnet is 2001:8:85A3:4000::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF18:7DE8