Sie sind auf Seite 1von 2

CCNA Vorbereitung

15.7.2 RoSt router on a stick


Ein externer Router mit mindestens einem FastEthernet-IF, das in SubInterfaces aufgeteilt
wurde (pro VLAN ein SubInterface) Router-on-a-Stick.

Dabei wird auf jedem SubInterface eine gltige IP Adresse eines VLANs konfiguriert.
Der Router routet dann zwischen diesen logischen Interfaces den Datenverkehr fr die
unterschiedlichen VLANs ber die einzelne physikalische Verbindung.

Die Verbindung zwischen Router und Switch ist als Trunk zu konfigurieren

RoSt Topologie mit 3 VLANs

Besonderheiten der Konfiguration von RoSt:


Bei der Konfiguration der SubInterfaces ist zuerst das Trunking Protocol und dann die
IP Adresse zu konfigurieren (im umgekehrten Fall wird die IP Adresse nicht akzeptiert
und eine Fehlermeldung generiert).

Das physikalische Interface muss aktiviert sein (no shutdown). Alle bereits vorhandenen
und zuknftig definierten SubInterfaces sind dann ebenfalls aktiviert.

dot1q - das native VLAN (Frames werden nicht getaggt) kann auf zwei unterschiedliche
Arten festgelegt werden
Konfiguration des physikalischen Interface fr das native VLAN, dort wird dot1q
nicht konfiguriert nur die IP Adresse.
Konfiguration von dot1q auf einem SubInterface mit dem Kommando native
(ab IOS 12.1(3)T).

ISL es muss fr alle VLANs ein SubInterface verwendet werden, ein native VLAN hat
bei ISL keine Bedeutung (alle Frames werden gekapselt).

160 2004-2010 R.Pohlmann@ping.de


CCNA Vorbereitung

Auszug running-config .. am Beispiel der Abbildung (s.o.)


FastEthernet Konfiguration auf dem Router (bei Verwendung von dot1q):
Variante 1: mit Konfiguration des physikalischen Interface fr das native VLAN 1
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
no shutdown
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.254 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.254 255.255.255.0
!

Variante 2: mit Konfiguration eines SubInterface fr das native VLAN 1


!
interface FastEthernet0/0
no ip address
no shutdown
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.254 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.254 255.255.255.0
!

FastEthernet Konfiguration auf dem Router (bei Verwendung von ISL):


!
interface FastEthernet0/0
no ip address
no shutdown
!
interface FastEthernet0/0.1
encapsulation isl 1
ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation isl 2
ip address 192.168.2.254 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation isl 3
ip address 192.168.3.254 255.255.255.0
!

161 2004-2010 R.Pohlmann@ping.de